Firefox persists in Task Manager indefinitely after being closed

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
2 years ago
2 years ago

People

(Reporter: lioncrusher, Unassigned)

Tracking

47 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

I have Windows 7 x64 Home Premium on a Samsung Laptop, and currently have Firefox 47.0.  This is not specific to this version of Firefox and has been going on for at least the past few months.  

When I close Firefox, the program looks like it closes, the window disappears.  But when I use my computer later, and click on the Firefox icon to open the program, it says it is already open and to close the program.  It remains in the task manager, sometimes with several versions of Flash and the Plugin Container as well.  I have to manually End Task on all of these.  The problem happens regardless of being in Safe Mode or disabling all plugins.  In fact, several times this persistent program hang has triggered my antivirus for suspicious activity.  It has also caused Firefox to crash at random times.

The only thing I have found that prevents this from happening is by disabling the "Clear History on Close" option.  That being said, I love this feature because it makes Firefox run (and load) so much faster if the history and cache are kept clear.  I would like to use this option without it causing Firefox to hang in the Task Manager.


Actual results:

Please see above: program is not exiting properly and hanging in the Task Manager indefinitely (will not close on its own after any period of time, I have to manually End Task in task manager)


Expected results:

Firefox should close and be out of the Task Manager within seconds after closing each time.  I should be able to use a feature of Firefox without it crashing or hanging the program or triggering my Antivirus.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hello there, could you please check the windows event logs? There should be a reason in there for which the Firefox is not allowed to close. You could also save them and attach them to the bug. Also, the antivirus could be at fault, you would want to check the antivirus logs as well. If anything seems relevant you could attach those to this bug as well.
Also please post the model and version for your antivirus.

Last but not least you would want to try running Firefox in safe mode: (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) it's possible that you might have an add-on that it's causing this and testing with Firefox in safe mode will exclude this scenario.
Flags: needinfo?(lioncrusher)
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

2 years ago
Hello:

I checked the Windows Event Logs for the day/time the error most recently happened, and no log was generated.  There was a General Behavior Detection by my antivirus, however.  I can post the info here:

Identity Protection Results
Threat Name;"Status";"Detection Time";"Object Type";"Process"
General behavioral detection, C:\PROGRAM FILES (X86)\MOZILLA FIREFOX\UPDATED\FIREFOX.EXE;"Unresolved";"6/9/2016, 7:12:20 AM";"File or Directory";""

My antivirus program is AVG Internet Security v 16.81.7639, Framework version: 1.92.2.15748

I am currently not having the problem now.  I disabled then re-enabled the Clear History on Exit setting.  It is very hard to reproduce this issue because it does not do it all the time. 

----------------

However, I do have Windows Event Logs from previous events that I can post here:

This is from 5/3/2016

Application 'C:\Program Files (x86)\Mozilla Firefox\firefox.exe' (pid 4436) cannot be restarted - Application SID does not match Conductor SID..

If the problem happens again, I will give you further details.
Googling around about the Event Log you posted, seems like the error "Application SID does not match Conductor SID." is generated when an elevated update check is attempted:
"https://social.msdn.microsoft.com/Forums/windows/en-US/c4bf8857-144f-46f8-93b7-a9cb5109c6fd/restart-manager-fails-to-restart-an-application-for-standard-users-in-windows-7?forum=winformssetup"
I'm not entirely sure if this is our case here, but maybe in correlation with your antivirus something weird is happening there. I have a hunch that the problem might be reproducible around the update. I also assume you have administrative rights and not using a standard user.


If you have time, could you try the following:
1. Uninstall your Firefox.
2. Install Firefox version 46: http://archive.mozilla.org/pub/firefox/releases/46.0.1/win32/en-US/Firefox%20Setup%2046.0.1.exe
3. Installing 46 will have your Firefox update to the latest version which is 47.

Also, if you manage to get the bug to reproduce with the above steps, try them again turning off the antivirus.
Due to the delayed response from Lioncrusher, resolving issue as incomplete for the moment. The bug shall be reopened when new information is brought up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(lioncrusher)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.