Closed Bug 1279747 Opened 6 years ago Closed 6 years ago

File Bookmark got broken recently

Categories

(SeaMonkey :: Bookmarks & History, defect)

SeaMonkey 2.40 Branch
Unspecified
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1249536

People

(Reporter: joanna.j, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build ID: 20160120191716

Steps to reproduce:

Bookmarks->File Bookmark... the problem is on the dialog


Actual results:

The browser no longer allows me to actually browse my bookmarks, so I can't find the subfolder I want to file the bookmark in


Expected results:

Traditionally this worked -- there was a file tree that let you browse down to the folder you wanted to file the bookmark under.
OS: Unspecified → Mac OS X
To be honest, I haven't a clue what the problem might be. 

Durrently NOT reproducible with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit:

1. Open this page in Browser
2. Menu 'Bookmarks → File Bookmark ...'
   » Dialog opens
3. right from Folder Selector with contents "Bookmarks Menu" click [▼] if
   folder pane below selector is empty
   » Folder pane shows some contents, but has insufficient height because of
     "Bug 1249536 - Too small height of Folder Pane in menu 'Bookmarks → 
     File Bookmark ...'"
4. Increase dialog height by drag and drop downwards bottom border of 
   dialog
   » height of folder pane becomes sufficient to show folder and subfolder 
     structure (see screenshot)

Reporter: 
Does Bug 1249536 describe your problem?

If not please:
a) Contribute a problem related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem due to 
   <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
   (similar to my steps)
b) Attach screenshots with comments if you believe that that might explain the 
   problem better than a text comment. Best way is to insert your screenshots
   into a OOo or LibreOffice DRAW document and to add comments 
   that explain what you want to show (attach .png or PDF from source document)
c) add information 
c1) concerning your Operating System (Language)
c2) concerning your SM localization (UI language, Locale setting)
c3) SM settings that might be related to your problems 
    May be you should attach a copy of menu 
   'Help → Trouble shooting information”' as a text document
c4) how you launch SM (Double click on document? console? …)
c5) Whether problem persists in safe mode without add-ons
c6) Whether problem persists with blank new profile
c7) everything else crossing your mind after you read linked texts
Flags: needinfo?(joanna.j)
Joanna,

please take a look at bug 1249536. This might be your problem.
Attached image picture of the bug
Is this too small a browser window?
It might be the problem, but I'm not sure.  There's no way to swing the arrows around and expose the full browsing window like you would often get on a mac, but I'm not sure that you needed to do that in SeaMonkey before.  it looks like someone stuck a new window template on that has lots of not very useful fields and then broke the main useful field.   I'm not sure whether the diagnosis that the one field isn't big enough is really the right one, maybe that's why the other bug is still not properly diagnosed?  Normally I should be able to scroll even if the window was too small using two finger drag on the track pad, but I can't do that.  Either I see a tiny random subset of my actual folders, or I only see the one line as shown in the figure.  I hope the figure helps.
Yes, that's the problem. Please take a look at:

http://forums.mozillazine.org/viewtopic.php?f=40&p=14617745

You can add some code to your userchrome.css file and fix it temporary yourself. The real fix will hopefully be in the next version which at this point in time is 2.44. ETA unknown because of broken infrastructure.

Closing this bug as a dpulicate. If you have a problem with the temp fix just holler.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(joanna.j)
Resolution: --- → DUPLICATE
Duplicate of bug: 1249536
You need to log in before you can comment on or make changes to this bug.