Modal find-in-page creates scrollbar when yellow popup appears, if page has DOCTYPE declaration (standards mode)

RESOLVED DUPLICATE of bug 1279742

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 1279742
2 years ago
2 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

50 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8762335 [details]
testcsae 1

STR:
 1. Load attached testcase.
 2. Press Ctrl+F
 3. Type in "H" or any character that appears on the page.

ACTUAL RESULTS:
In step 3, when the yellow popup appears, a vertical scrollbar also appears (suggesting that we've created something that's taller than the viewport, or positioned something just off the bottom).

EXPECTED RESULTS:
No vertical scrollbar. This page only has a single line of text; there's nothing to scroll to, vertically.


I'm guessing maybe the overlay uses a "height:100%" element which is offset by a little bit, or something like that, which ends up overflowing the viewport by just a little bit...
(Reporter)

Comment 1

2 years ago
Marking this as a "regression" from the modal find-in-page feature, since this didn't happen with the old find-in-page UI.
Blocks: 384458
Keywords: regression
[Tracking Requested - why for this release]: Regression
status-firefox49: --- → unaffected
status-firefox50: --- → affected
tracking-firefox50: --- → ?
Version: unspecified → 50 Branch
(Reporter)

Comment 3

2 years ago
Thanks for connecting this to bug 1279742 -- I think this is actually a dupe of that bug, based on the testcase/screenshot over there.

--> Duping, and clearing tracking / affected flags, so we don't track this same bug in 2 places (and have to worry about stale flag-settings on this bug here after the dupe-target bug is fixed).
No longer blocks: 384458
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox49: unaffected → ---
status-firefox50: affected → ---
tracking-firefox50: ? → ---
No longer depends on: 1279742
Resolution: --- → DUPLICATE
Duplicate of bug: 1279742
You need to log in before you can comment on or make changes to this bug.