FIrefox hangs ( titech.ac.jp )

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Akihiro Nomura, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

1. Go this URL
   http://mon.g.gsic.titech.ac.jp/
2. Click "Failure History", at right-bottom
   http://mon.g.gsic.titech.ac.jp/trouble-list/


Actual results:

Firefox stop responding, cannot close the tab.
I'm using Windows 10 64bit, and not sure whether this is reproduced in different OS etc, but reproduced on my colleague's PC.


Expected results:

The page is displayed without hang, or at least Firefox should respond so that I can stop the loading.

When I try the same URL with IE, the page is displayed without any problem.

Comment 1

2 years ago
WFM with FF47, even if there is delay during loading the page (with long table).

Could you test with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(sacredfox)

Comment 2

2 years ago
Loic, 

I can load the 

http://mon.g.gsic.titech.ac.jp/trouble-list/index.htm

page without problems but when I try to view the source code, then the whole window becomes unresponsive. Can you reproduce this? 

I am using Firefox 47 buildID=20160606114208 under Linux 3.13.0-88-generic x86_64, Qt: 4.8.6, KDE 4.13.3, Kubuntu (trusty) 14.04.4 LTS.

- - - - - - 

The page is generated by Microsoft Office Excel 12.0 and it has hundreds of "mso-" prefix properties.

Start of code is:

<html xmlns:v="urn:schemas-microsoft-com:vml"
xmlns:o="urn:schemas-microsoft-com:office:office"
xmlns:x="urn:schemas-microsoft-com:office:excel"
xmlns="http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=Content-Type content="text/html; charset=shift_jis">
<meta name=ProgId content=Excel.Sheet>
<meta name=Generator content="Microsoft Excel 12">
<link rel=File-List href="index.files/filelist.xml">

Examples of "mso-" prefixed properties:

 	mso-displayed-decimal-separator:"\.";
	mso-displayed-thousand-separator:"\,";
	mso-font-charset:128;
 	mso-font-charset:0;
 	mso-ignore:padding;
	mso-number-format:"yyyy\/mm\/dd";
 	mso-background-source:auto;
 	mso-pattern:auto;
	mso-number-format:General;
 	mso-background-source:auto;
 	mso-pattern:auto;

The source code has 90526 (!!) lines, has thousands of inline style declarations, dozens of rules, has a table with 5306 table rows, approx. 53015 table cells with each table cell with a classname, width, border and height declarations, etc... It is definitely an extremely big table which can easily overload any application or system.

- - - - - 

For specific types of bugs like hang or crash, there is this page:
https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines#For_specific_types_of_bugs

How to Report a Hung Firefox
https://developer.mozilla.org/en-US/docs/Mozilla/How_to_report_a_hung_Firefox
20160604131506 Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
20160615030209 Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

I have tested the issue on latest FF release 47.0 and latest Nightly build and could not reproduce it.
There is delay during loading, both for http://mon.g.gsic.titech.ac.jp/trouble-list/ and for View source code, but the pages are displayed correctly without hang.

Please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.
Please test if the issue can be reproduced in the safe mode of Firefox: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Comment 4

2 years ago
Roxana,

I retested the loading and viewing source of the page with Firefox nightly (Firefox 50.0a1 buildID=20160616021437). The page loads after 12-15 seconds on my system. The source code loads in a separate window after 40-45 seconds. During the load (of page or of source code), my CPU activity increases to at least 50% and remains there during the load delay. 

Closing the tab or the source code window also takes a few seconds while the CPU activity remains above 50%. There is no doubt that such page is very demanding for any application or system as it requires a lot of CPU and RAM.

My guess is that, if the user is not patient, he will want to try to close the tab while the operating system is very busy actively trying to load the page. At that point, the user will notice the Firefox does not close the tab instantly and that the application may appear to the user to be unresponsive or hanging.

Comment 5

2 years ago
Not a surprise that 'dummy' webpages wih heavy tables are long to load and display, even for the source code. I'm pretty sure there is an old bug about issues when viewing source code for long tables.

Comment 6

2 years ago
It's not just an heavy table. It's also proprietary code, over-declared CSS inline styles, "classitis" and over-specified table formatting.

I use the extension HTML validator 0.9.6.6 and it requires CPU and RAM to parse source code. So, this extension impacts the delay I get and the CPU activity percentage I get.

- - - - - - 

Akihiro, 

If you could reach the webmaster of Tokyo Institute of Technology and let him/her know that such webpage is not suitable for most people as it creates an excessive load on the users' system resources, that would be best, I think. Over here, in all fairness, Firefox does not hang and Firefox is not the problem.

Resolving as WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(sacredfox)
Resolution: --- → WORKSFORME
Summary: FIrefox hangs when try to open specific URL → FIrefox hangs ( titech.ac.jp )
You need to log in before you can comment on or make changes to this bug.