Normal Select cursor changes to Text Select cursor for Search Suggestion strings

VERIFIED FIXED in Firefox 50

Status

()

Firefox
Activity Streams: Newtab
VERIFIED FIXED
2 years ago
2 months ago

People

(Reporter: cmuresan, Unassigned)

Tracking

Trunk
Firefox 50
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(2 attachments)

Created attachment 8762555 [details]
suggested strings are somewhat selectable.mp4

[Affected versions]:
- Firefox 45.0 and up
- Activity Stream 1.1.0-dev

[Affected Platforms]:
- All Windows
- All Mac OS X
- All Linux

[Prerequisites]:
- Latest Activity Stream add-on version (1.1.0-dev) was previously installed on a clean profile.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites. 
2. Open a New Tab and write a keyword in the Search bar.
3. Hover a few of the suggested keywords.

[Expected result]:
- Normal Select cursor is kept while hovering suggested keywords.

[Actual result]:
- The mouse pointer switches from "Normal Select" to "Text Select".

[Notes]:
- Attached a screen recording of the issue.
via https://github.com/mozilla/activity-stream/pull/865/commits/61df6fb0a1a7d52d82dd2d1e4addab7e1f4a5b96
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Created attachment 8763902 [details]
text cursor still displayed

This issue has been verified on Win 10 x64, Mac OS X 10.11 and Ubuntu 14.04 x64 with latest Nightly 50.0a1 (Build ID: 20160620030215) using latest Activity Stream v1.1.0-custom build and it is partially reproducible.
If the "Google Search" and "Search for...with" elements from the Search Suggestion dropdown are hovered, the mouse cursor changes to Text Select cursor. This behavior can be observed in the attachment.

Also, while testing, we observed that the written string from the New Tab Search Box is displayed with a gray color instead of black in the "Search for...with" element.

Thus, marking this issue as Reopened.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
via https://github.com/mozilla/activity-stream/pull/869
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
This issue has been verified on Win 8.1 x64, Mac OS X 10.11 and Ubuntu 15.10 x64 with latest Nightly 50.0a1 (Build ID: 20160621030208) using latest Activity Stream v1.1.0-custom build and could not reproduce it.
Thus, marking this issue as Verified-Fixed.
Status: RESOLVED → VERIFIED

Updated

2 months ago
Target Milestone: --- → Firefox 50
You need to log in before you can comment on or make changes to this bug.