WebExtensions: Contents of pageAction and browserAction popups are rendered far too large and overflow

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: dw-dev, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

I have migrated my Search Site add-on to the new WebExtensions API.

It was working perfectly, but a few weeks ago the page action popup started to display incorrectly.  The contents of the popup are rendered many times too large and overflow the popup window, causing horizontal and vertical scroll bars.

This problem occurs in Firefox 47 & 48 and Nightly 50.

I have tried installing two of the WebExtensions example add-ons (Beastify and QuickNote) and their browser action popup windows are also displayed incorrectly.



Actual results:

The contents of the popup are rendered many times too large and overflow the popup window, causing horizontal and vertical scroll bars.


Expected results:

The page/browser action popup windows should render correctly.
(Reporter)

Comment 1

2 years ago
After some more testing, I have just realized that this problem is caused by the zoom level in page/browser action popups not being correctly set by another add-on.

There this bug report has been closed as RESOLVED INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.