pages load relatively slow on firefox compared to chrome

UNCONFIRMED
Unassigned

Status

()

P3
normal
UNCONFIRMED
3 years ago
a year ago

People

(Reporter: amogh.kudari5, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

Attachments

(2 attachments)

252.83 KB, application/x-rar
Details
14.91 KB, application/x-rar
Details
(Reporter)

Description

3 years ago
Created attachment 8762696 [details]
facebook.rar

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

Entered url http://www.facebook.com on firefox and hit enter



Actual results:

Loads very slow and did not load the page properly(Screenshot attached) (without clearing cache). It did load properly after refresh. 
Where as it loaded properly on chrome at first go even after I cleared history and chrome cache.
Most of the web pages load very slowly on firefox as compared to chrome.



Expected results:

Should have loaded facebook page fast and properly.

Comment 1

3 years ago
Dis you test in safe mode?
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

With a fresh profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(amogh.kudari5)
(Reporter)

Comment 2

3 years ago
Hi Loic,

  I had tried with safe mode, it was working slow.
But with fresh profile, it works pretty fast. 
My concern is not only this link(www.facebook.com), but in general, every time I load a new URL(which is not accessed earlier), firefox takes comparatively more time than chrome, and sometimes pages are even not loaded at first go.
But later if I load it on chrome and then try loading on firefox, it works.
Eg: I had raised a bug earlier, https://bugzilla.mozilla.org/show_bug.cgi?id=1273558, where firefox was not loading my ISP page, then I had to load my ISP page and then access it in firefox. I still sometimes face this problem, event though bug has been closed.

I know this is kind of generic observation I am providing, but, this is what I have experienced with firefox.

Hope, this explains the problem...
20160604131506 Mozilla/5.0 (Windows NT 6.1; rv:47.0) Gecko/20100101 Firefox/47.0
20160616030228 Mozilla/5.0 (Windows NT 6.1; rv:50.0) Gecko/20100101 Firefox/50.0

I have tested the issue on latest FF release 47.0 and latest Nightly build and could not reproduce it.
Please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.
Component: Untriaged → Networking
Product: Firefox → Core
some of the performance difference wrt facebook is that chrome does pre-rendering and we don't (yet).

however I am interested in the case where nothing seems to load at all.

If you can capture that in an HTTP_LOG that would help.
https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging
Whiteboard: [necko-backlog]
(Reporter)

Comment 5

3 years ago
Created attachment 8763842 [details]
nw_logs.rar

Hi Patrick,

      Sorry for late reply, I tried reproducing the issue with safe mode with all history deleted and cache and cookies cleared, but was unable to(especially where nothing loads). I do have attached the web console logs of both chrome and Firefox. Chrome's network logs are in har file format. As you said may be it's because of pre-rendering.But still, I feel the way chrome gets the data from network is pretty much faster compared to Firefox, may be it's due to architecture, not sure though. I have used chrome with --disable-extensions and cleared it's history, cache and cookies to collect the network logs. My chrome version is 51.0.2704.103m.
Hope these network logs help. If possible, I will collect network logs from other websites and post it.
Flags: needinfo?(amogh.kudari5)
You need to log in before you can comment on or make changes to this bug.