script errors on nearly every WordPress site using advertings since update to ver 47.0

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: firefox@rickrichbourg.com, Unassigned, NeedInfo)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

after updating to version 47.0 visiting websites using WordPress AND using scripting from 3rd party advertisers 


Actual results:

Firefox browser freezes  and 'stop script' dialog box does NOT stop script - browser becomes unresponsive and the only way to resolve the issue is to invoke windows 7 task manager and close out the entire browser window. Losing of course, all info in other related tabs.


Expected results:

browser should function normally and not 'lock up' when being served 3rd party scripts.

Comment 1

2 years ago
Could you test:
1) in safe mode:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Does it work better?
Flags: needinfo?(firefox)
(Reporter)

Comment 2

2 years ago
Thank you for your reply...

No, does NOT work better. The errors still persists, not only, in safe mode; but also with new profile as well...

I can upload snippets of errors  if that would be helpful... pre-safe mode, safe mode and new profile. However, they are all variants of this same error message:

 "Warning: Unresponsive Script"
"A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue."

The message the goes on to display the name of the script, then presents the buttons to continue, debug or stop.

Please appreciate that once the dialog box is invoked, pressing stop, does NOT stop the script. Instead, the dialog box disappears, all or any open window(s) are non responsive. Occasionally, I am able to stop the script after click the stop button multiple times. Most of the time, I must use task manager to close out Firefox and restart...

Again, thank you for your response and suggestions.

Please let me know if I can provide any additional info to clarify the situation.
20160604131506 Mozilla/5.0 (Windows NT 6.1; rv:47.0) Gecko/20100101 Firefox/47.0
20160607062931 Mozilla/5.0 (Windows NT 6.1; rv:50.0) Gecko/20100101 Firefox/50.0

Hi,
I have tested the issue with several websites that are using WordPress on latest FF release 47.0 and latest Nightly build and could not reproduce it. 
Can you please provide a website with you can reproduce the issue?

Please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.
(Reporter)

Comment 4

2 years ago
Greetings and thank you for your reply and suggestions. 

I've updated to the nightly build and will begin testing.

For those requesting websites uri's casing my issues, here are a couple: 
http://www.exclutips.com/wordpress/9-most-useful-htaccess-tricks-for-wordpress/
http://drudgereport.com/

Regarding the last site, this script in particular seemed to be one of the culprit: 
http://cdn.intermarkets.net/u/Intermarkets/DrudgeReport/drudgereport_targeting.js

again, thanks for all the help.
Considering the fact that I cannot reproduce this and the fact that the reporter did not provided details after testing with Nightly I will mark this as Resolved-Worksforme.

If anyone can still reproduce it, feel free to reopen the issue and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

2 years ago
Roxana, 

thank you for your latest input. As I mentioned in comment # 4, I did indeed update to "Nightly" build... In addition to the URL's listed in comment 4 as causing issues, here are a couple of more URL's that were problematic

http://www.breitbart.com/
this script is part of the problem >  Script: http://www.breitbart.com/:0

This site is also problematic > http://www.thesaurus.com/browse/

Please note, that I am currently using Nightly - build 50.0a1 (2016-07-12) and while issues have lessened from my original post; they are still intermittently occurring =:o 

again, thank you for your help.
Please note that I checked the provided "problem" links on several machines (Windows7 and other OSes) with no luck. I didn't experience any kind of issue.

One possible problem that would explain the fact that I cannot reproduce the behavior you are reporting might be the existence of a malware on your computer. So, before thinking of trying anything else, could you please check you computer for malware?
You need to log in before you can comment on or make changes to this bug.