Closed Bug 1280221 Opened 5 years ago Closed 5 years ago

In Inspector, Fonts view shows in CSS pane tab dropdown menu even if it is disabled in config

Categories

(DevTools :: Inspector, defect)

47 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1259892

People

(Reporter: elmo.allen, Unassigned)

Details

Attachments

(1 file)

Attached image css-pane-fonts-tab.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

Set devtools.fontinspector.enabled to false. Open the Inspector on any page. Adjust the CSS pane so small that all the tabs cannot fit the window. Open the tab dropdown menu.


Actual results:

The dropdown menu shows "Fonts". Clicking the Fonts opens otherwise an empty tab in the CSS pane, but it shows "See all the fonts used in the page" link on the bottom. Clicking the link does nothing.


Expected results:

The Fonts tab would not show in the dropdown menu, unless devtools.fontinspector.enabled is set to true.
Component: Activity Streams: General → Developer Tools: Font Inspector
This has been fixed in FF48 by bug 1259892.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1259892
Product: Firefox → DevTools
Component: Inspector: Fonts → Inspector
You need to log in before you can comment on or make changes to this bug.