Firefox for Android about:crashes has missing items

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: andrei, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Android 5.1.1; Mobile; rv:49.0) Gecko/49.0 Firefox/49.0
Build ID: 20160614004007

Steps to reproduce:

1) Crash Firefox Nightly for Android (it crashes often)
2) go to about:crashes


Actual results:

only one item is present but it is from another day


Expected results:

A crash report for today that is my curent crash.
If I don't see my crashes neither does Mozilla so priorities for issues might be wrong
(Reporter)

Updated

2 years ago
Component: Untriaged → General
Product: Firefox → Firefox for Android
Version: 49 Branch → 50 Branch
(Reporter)

Comment 1

2 years ago
This happens both on Nightly and Aurora.
Do you see the Mozilla Crash reporter when you crash? https://support.mozilla.org/en-US/kb/mozillacrashreporter if you don't see the crash reporter then this is expected behavior.
Flags: needinfo?(andrei)
(Reporter)

Comment 3

2 years ago
I see the crash reporter every time. It shows me "what were you doing when it crashed", "your email", "close/restart nightly".

It happens when I switch somehow to firefox. Either I swipe the lock screen and the last opened app was Nightly and then instead of Nightly I see the crash reporter. Some other times it happens when I open Nightly from an RSS feed like ownCloud rss reader. And some other times when I go to overview to see all aps and click Nightly and bam: crash reporter.

I started using Nightly and Aurora on Android since Nightly was version 49 and Aurora v48. It seemed like Aurora was more stable then and now they both crash equally often.

If you can provide a Nightly build that logs lots of stuff for troubleshooting I can gladly install it and send you logs.
(Reporter)

Comment 4

2 years ago
I think Mozilla might be really interesged in this bug before it reaches stable. I noticed it since firefox crashes every time I unlock my phone. Every time. I think Mozilla mises a lot of crashes due to this issue.
(Reporter)

Comment 5

2 years ago
If this were a desktop Firefox and not an Android firefox issue I would probably start FF Nightly from the command line and pipe all the output to a file. Any clue how I can do that on Cyanogen mod? I am root :)
(Reporter)

Comment 6

2 years ago
I see the crash reporter but no crash after in about:crashes.

I just figured out how to remove the needinfo flag. Bugzilla n00b here :)
Flags: needinfo?(andrei)
(Reporter)

Comment 7

2 years ago
I'm sorry but I will stop testing Nightly and Aurora until this is fixed or somebody will work on this. I cannot use it as my main browser on my CyanogenMod. I will use GNU Icecat as my main browser until somebody will work on this.

Comment 8

2 years ago
Hey Andrei, 
We are not able to reproduce this on any device in the office on Android builds. Can you let us know which device are you using and which Cyanogen version do you have on it?  

Can you please verify that you have the "Tell Mozilla about this crash so they can fix it" box checked?
Also, can you connect to the SDK and let us know what error it generates while crashing?

Thanks!
Flags: needinfo?(andrei)
(Reporter)

Comment 9

2 years ago
 - Samsung galaxy S5 Plus G901F;
 - CyanogenMod: 12.1-20150517-UNOFFICIAL-kccat6xx (It's the only CyanogenMod for this device); Basebuild version: G901FXXU1BOC4; Android Version 5.1.1;
 - I have "Tell Mozilla about this crash so they can fix it" checked;

How can I connect it to the SDK?
(Reporter)

Updated

2 years ago
Flags: needinfo?(andrei)
(Reporter)

Comment 10

2 years ago
I want to be clear: there are crashes in about:crashes but not the number I expected to be. I am uploading crashes.

The problem is that it crashed all the time..... probably 5 to 10 times a day and I had like 2 or 3 crash reports that were old. Now I just reinstalled and I simply cannot make Nightly crash again. I switched to Nightly as the default browser on my phone and I want to see if this happens again.

This started with version 49 as Nightly. When 49 was promoted to Aurora both Nightly and Aurora crashed and now none of them do. I will leave this bug report like it is for a month or so and If I don't manage to reproduce it anymore I will mark it as solved.
(Reporter)

Comment 11

2 years ago
I'm closing this one since it does not reproduce anymore. I am on Nightly as my main browser on my phone and all is ok. I tested with Aurora and no issues there either. I don't understand it but I'm glad that it's fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.