[IOS 10] Menu is not fully displayed in landscape view

RESOLVED FIXED

Status

()

Firefox for iOS
Menu and Toolbar
P1
normal
Rank:
1
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: SimonB, Assigned: sleroux)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios5.2+, fxios-v5.0 affected, fxios-v5.1 affected, fxios-v5.2 verified, fxios-v6.0 fixed)

Details

(Whiteboard: [MobileAS])

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8763096 [details]
IMG_0090.PNG

Build: 5.0b11
Device: Iphone 6 S (ios 10)

Steps to reproduce:
1. Launch Firefox and change device orientation to landscape
2. Open the menu

Actual:
- The menu is not fully displayed.
Depends on: 1280461
tracking-fxios: ? → 6.0+
Saw this on my iPad Pro yesterday (iOS 10 Beta 4)
tracking-fxios: 6.0+ → 5.2+
(Reporter)

Comment 2

a year ago
Tested on:
Build: 5.1b3
Device: iPad mini 4
iOS: 10b6

The issue is reproducible.
status-fxios-v5.1: --- → affected
Whiteboard: [MobileAS backlog]
Rank: 1
Whiteboard: [MobileAS backlog] → [MobileAS]
(Assignee)

Updated

a year ago
Blocks: 1280461
No longer depends on: 1280461
(Assignee)

Comment 3

a year ago
Possibly related to intrinsticContentSize being zero.
Priority: -- → P3
Priority: P3 → P1
(Assignee)

Updated

a year ago
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
Duplicate of this bug: 1291325
(Assignee)

Comment 5

a year ago
Created attachment 8785962 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/2070

Passing the review over to you but if you don't have an iOS 10 device to test on I can assign to someone else!
Attachment #8785962 - Flags: review?(etoop)
Comment on attachment 8785962 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/2070

I think this fix is doing too much and causing the MenuView layout code to be called too many times when the menu is displayed. I have left a suggested alternative fix in the PR.

:farhan - What should I do with this given :sleroux is on PTO?
Flags: needinfo?(fpatel)
Attachment #8785962 - Flags: review?(etoop) → feedback+
Steph said he'll be on and off. I think he should be able to land this.
Flags: needinfo?(fpatel)
(Assignee)

Comment 8

a year ago
Thanks for the alternative :fluffyemily! I've used that instead and gave it a test and works the same without the performance hit. I'll land that instead.
(Assignee)

Comment 9

a year ago
master b607bab40b46e3647a1bcfed630cf480c1ae24cf
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-fxios-v6.0: --- → fixed
Resolution: --- → FIXED
Whiteboard: [MobileAS] → [MobileAS] [needsuplift]
(Assignee)

Comment 10

a year ago
v5.x d5e33d7
status-fxios-v5.2: --- → fixed
Whiteboard: [MobileAS] [needsuplift] → [MobileAS]
(Reporter)

Comment 11

a year ago
Tested on iPad mini 4 running iOS 10b8 on 5.2b2.

The issue is not reproducible following the above STR.
status-fxios-v5.2: fixed → verified
Iteration: --- → 1.3
You need to log in before you can comment on or make changes to this bug.