unable to connect to pop3 servers outside of originating domain

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: David.Margery, Assigned: naving)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
since mozilla9-8, I'm unable to connect to mail accounts using pop servers
outside my originating network (2 accounts affected, systematic).
It's not a firewall problem, as I can still currently access those accounts with
mozilla9-7

The problem arose at the time I downloaded build 9-8, and in the same time
configured my main account to use SSL. Nevertheless, disabling SSL doesn't
correct the problem  (this is prpably unrelated)

Could be linked to bug #127461
(Assignee)

Comment 1

17 years ago
Are you using direct connection to internet or relying on proxies. 
(Reporter)

Comment 2

17 years ago
Yes, the problem is with the automatic proxy.
With direct connection, the problem doesn't appear

The proxy used is domain wide, with the following configuration
function FindProxyForURL(url, host)
{
  if ( shExpMatch(url, "https://*") )
    return "DIRECT";

  if ( shExpMatch(url, "nfs:/*") )
    return "PROXY www-interne.irisa.fr";
  
  if ( shExpMatch(url, "wais://*") )
    return "PROXY www.irisa.fr:8001" ;

  if ( isInNet(host, "131.254.0.0", "255.255.0.0") || isInNet(host, "127.0.0.0",
"255.255.0.0"))
    return "DIRECT";

  if ( shExpMatch(url, "http://*/cgi-bin/*") || shExpMatch(url, "http://*.cgi")
|| shExpMatch(url, "http://*.univ-rennes1.fr/*") )
    return "DIRECT";

  if ( shExpMatch(url, "http://*/*.asp") )
    return "DIRECT";

  if (isPlainHostName(host))
    return "DIRECT";

  if (shExpMatch(host, "*.inria.fr")) 
    return "DIRECT";

  if (shExpMatch(host, "galaad.dsi.cnrs.fr"))
    return "DIRECT";

  if (shExpMatch(host, "www.lemoniteurbtp.com"))
    return "DIRECT";

  return "PROXY www-cache.irisa.fr:XXXX; DIRECT";
}

Comment 3

17 years ago
I have the same problem, I am using a proxy too.
But for me Mozilla 0.9.8 is working, but later versions (0.9.9, 1.0) do not work
with the proxy.
The problem also happens when using the local Norton Antivirus POP-Server
(pop3.norton.antivirus at 127.0.0.1) for scanning e-mails.

Updated

16 years ago
QA Contact: sheelar → esther

Comment 4

16 years ago
Can you please see if this works on a recent build? This is very old, and I
can't reproduce. Adding qawanted keyword.
Keywords: qawanted
(Reporter)

Comment 5

16 years ago
OK, bug seems to have disapeared.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 6

16 years ago
Verifying, though, it really should be WFM, and not Fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.