Closed Bug 1280539 Opened 4 years ago Closed 3 years ago

Popular sites open in reader mode

Categories

(Firefox for Android :: General, defect)

48 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 50
Tracking Status
firefox48 --- verified
firefox49 --- verified
fennec 48+ ---
firefox50 --- verified

People

(Reporter: jdm, Assigned: ahunt)

References

Details

(Keywords: regression)

Attachments

(1 file)

Various entries from my top sites on the new tab page have started opening in reader mode by default. If I remove the item from the top sites, visiting the URL by typing it in the location bar does not open it in reader mode, but if I refresh it enough times then the history entry gains a blue mobile device icon on the right side of the screen, and from then on it opens in reader mode. This only started happening after I updated to 48.0b1.
Version: unspecified → 48 Branch
tracking-fennec: --- → ?
Flags: needinfo?(ahunt)
I suspect this is due to the fact that we open bookmarked reader view pages in reader view, combined with the fact that we migrated reading list items to bookmarks.

Josh, is there any chance that these could be pages you added to your reading list at one point in the past?

If you un-bookmark them and re-bookmark them in non-reader mode, I suspect this problem would go away.
Assignee: nobody → ahunt
tracking-fennec: ? → 48+
Flags: needinfo?(josh)
Removing it from the bookmarks list did fix the issue.
Flags: needinfo?(josh)
By default, i.e. for most lists in the homepanels, we want to open the offline reader-view version
of a page if the page is stored as an offline reader-view bookmark (TwoLinePageRow shows the bookmark
and offline status for pages, not only in bookmarks, but also in the list of top sites, awesomescreen
results, and history). The only exception is the topsites grid, where we don't offer any indication
of the bookmark or offline status of a page. For now the expectation is that topsites open the
normal version of a page, so we need to bypass the usual flow for that case.

(It's possible the UI around this would change in future, but with the current UI this is probably
 the most obvious / least frustrating behaviour.)

Review commit: https://reviewboard.mozilla.org/r/60874/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/60874/
Attachment #8765593 - Flags: review?(s.kaspari)
I'm not a huge fan of my patch since it introduces more reader-view special casing for the topsites grid, but it's probably the simplest way of fixing this issue for now. I wonder if we need better ways of displaying bookmark/offline status for the topsites grid, and also if we'd want to add a direct way of switching a bookmark from reader-view to normal bookmark (although that's probably not too important right now).
Flags: needinfo?(ahunt)
Comment on attachment 8765593 [details]
Bug 1280539 - don't open topsites into reader view if stored as offline reader-view page

https://reviewboard.mozilla.org/r/60874/#review57824
Attachment #8765593 - Flags: review?(s.kaspari) → review+
https://hg.mozilla.org/integration/fx-team/rev/ad555a4b249e64dc3fa00153df2202c78e83c04c
Bug 1280539 - don't open topsites into reader view if stored as offline reader-view page r=sebastian
Comment on attachment 8765593 [details]
Bug 1280539 - don't open topsites into reader view if stored as offline reader-view page

Approval Request Comment
[Feature/regressing bug #]: Bug 1234328
[User impact if declined]: TopSites (in the topsites grid) can open into readerview if they have been bookmarked as a on offline reader-view page, despite there being no indication that the page is an offline reader-view bookmark.
[Describe test coverage new/current, TreeHerder]: manual testing.
[Risks and why]: low-risk: additional flag used when opening pages from homepanels, this flag avoids us opening the reader-view version of a page for topsites.
[String/UUID change made/needed]: none.
Attachment #8765593 - Flags: approval-mozilla-beta?
Attachment #8765593 - Flags: approval-mozilla-aurora?
Comment on attachment 8765593 [details]
Bug 1280539 - don't open topsites into reader view if stored as offline reader-view page

This patch fixes a regression. Take it in 48 beta 5 and aurora.
Attachment #8765593 - Flags: approval-mozilla-beta?
Attachment #8765593 - Flags: approval-mozilla-beta+
Attachment #8765593 - Flags: approval-mozilla-aurora?
Attachment #8765593 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/ad555a4b249e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Verified as fixed in build:
- 48 Beta 6;
- Aurora 49.0a2 (2016-07-10);
- Nightly 50.0a1 (2016-07-10);
Device: LG G4 (Android 5.1).
Depends on: 1287060
You need to log in before you can comment on or make changes to this bug.