Devtools sometimes won't open on specific page

RESOLVED DUPLICATE of bug 983386

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 983386
2 years ago
2 years ago

People

(Reporter: Maël Lavault, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160606100246

Steps to reproduce:

Tried to open devtools after webpage reload (was doing local dev).

It opens if I go to another tab but won't open except if i close the tab and reopen my page in another tab.


Actual results:

Nothing. Here is the browser console stack:

 promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Date: Fri Jun 17 2016 11:50:57 GMT+0200 (CEST)
Full Message: TypeError: this._toolbox is null
Full Stack: InspectorPanel.prototype.selection@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/inspector/inspector-panel.js:130:5
nsContextMenu.prototype.inspectNode/<@chrome://browser/content/nsContextMenu.js:576:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:750:11
 inspector-panel.js:130:0
A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Date: Fri Jun 17 2016 11:51:03 GMT+0200 (CEST)
Full Message: TypeError: this._toolbox is null
Full Stack: InspectorPanel.prototype.selection@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/inspector/inspector-panel.js:130:5
nsContextMenu.prototype.inspectNode/<@chrome://browser/content/nsContextMenu.js:576:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:750:11
 inspector-panel.js:130:0
A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Date: Fri Jun 17 2016 11:51:14 GMT+0200 (CEST)
Full Message: TypeError: this._toolbox is null
Full Stack: InspectorPanel.prototype.selection@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/inspector/inspector-panel.js:130:5
nsContextMenu.prototype.inspectNode/<@chrome://browser/content/nsContextMenu.js:576:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:750:11
 inspector-panel.js:130:0
A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Date: Fri Jun 17 2016 11:50:41 GMT+0200 (CEST)
Full Message: TypeError: this._toolbox is null
Full Stack: InspectorPanel.prototype.selection@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/inspector/inspector-panel.js:130:5
nsContextMenu.prototype.inspectNode/<@chrome://browser/content/nsContextMenu.js:576:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:750:11
 inspector-panel.js:130:0
refresh: Checking updates for: WorkPoller batch.js:417:165
ajax  : executing request for workAllData batch.js:417:165


Expected results:

Devtools should open.
I'm moving the issue to Firefox - Developer Tools component. Activity Streams is an add-on and has nothing to do with your issue.
Component: Activity Streams: General → Developer Tools
(Reporter)

Comment 2

2 years ago
(In reply to Vlad Bacia [:VladB] from comment #1)
> I'm moving the issue to Firefox - Developer Tools component. Activity
> Streams is an add-on and has nothing to do with your issue.

Yes sorry I forgot to select the right component. Thanks !
Thanks for the report!

Can you provide more details about the context?  Do you see this on every site or only specific pages?  (I wasn't entirely sure from your description.)
Component: Developer Tools → Developer Tools: Inspector
Flags: needinfo?(mael.lavault)
(Reporter)

Comment 4

2 years ago
Yes, I see it a lot on the new website we are developing for our company. It's an isomorphic react app. I see it there a lot because I do a lot of refresh on the page. I don't know if it happens on other pages.
Flags: needinfo?(mael.lavault)
Could this be a duplicate of bug 983386? It looks that way to me.
Mael: can you confirm that this happens when you reload the page after Firefox had displayed an error page?
Flags: needinfo?(mael.lavault)
No answers from Mael after a few weeks. Going to close this as dupe of bug 983386 and leave the needinfo.
We can always change this later.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 983386
(Reporter)

Comment 7

2 years ago
Yes I confirm, it is a dupe, I missed the needinfo request, sorry !
Flags: needinfo?(mael.lavault)
You need to log in before you can comment on or make changes to this bug.