Closed Bug 1280614 Opened 4 years ago Closed 4 years ago

Buildbot build jobs overwrite index entries for TC builds

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1274311

People

(Reporter: whimboo, Unassigned)

Details

I noticed that the TC index does not list any (at least) opt builds as made via TC. Those are always the buildbot jobs. This is something which not happens with debug builds, where we can differentiate between those builds via `debug` vs. `dgb`. But given that for other builds we use the same type identifier for both buildbot and tc, only buildbot get its task indexed.

Could we update the routing keys for indexing the buildbot tasks so that those maybe get a `-bb` suffix? It would allow us to differentiate kinda easily between tc and bb tasks.
Buildbot task: https://tools.taskcluster.net/task-inspector/#HQ_BYAMIRqaZJG_LEYuNNg/
Taskcluster task: https://tools.taskcluster.net/task-inspector/#W6OMLbUmQquAXwDueslMPA/

Buildbot routes:
index.gecko.v2.mozilla-central.revision.05873df0c0c268e419a714b8a6204cb852049098.firefox.linux64-opt
index.gecko.v2.mozilla-central.pushdate.2016.06.16.20160616233045.firefox.linux64-opt
index.gecko.v2.mozilla-central.latest.firefox.linux64-opt

Taskcluster routes:
index.gecko.v2.mozilla-central.revision.05873df0c0c268e419a714b8a6204cb852049098.firefox.linux64-opt
index.gecko.v2.mozilla-central.pushdate.2016.06.16.20160616233045.firefox.linux64-opt
index.gecko.v2.mozilla-central.latest.firefox.linux64-opt
Looks like, yes.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1274311
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.