With proxy autoconfigure script in use, IMAP and NNTP connections hang when opened

VERIFIED DUPLICATE of bug 128045

Status

MailNews Core
Networking
VERIFIED DUPLICATE of bug 128045
17 years ago
10 years ago

People

(Reporter: Paul Coen, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020226
BuildID:    20020220603

On any build of Mozilla I've tried after 2002021510 (the next was probably
20020218x), IMAP and NNTP connections hang if you had a proxy autoconfiguration
file selected when Mozilla was first started. This is *not* a transparent or
manditory proxy. Mozilla tries to connect to the proxy server when I try to
connect to a local IMAP server, and any local or remote NNTP server. 

Configuring the proxy manually works. If you then re-select automatic
configuration and click on reload, IMAP and NNTP connections start to time out
again.

(The proxy autoconfig is so on-campus things work without going through
the proxy, and our off-campus students can get to certain resources by
redirecting through the proxy without having all their http traffic pass through
it.)

Reproducible: Always
Steps to Reproduce:
1.Edit | Preferences | Advanced | Proxies
2.Check off Automatic proxy, using http://web.drew.edu/proxyconf.cgi
3.Reload, or exit mozilla and restart it.
4.Go into Mail & News and try to open NNTP or IMAP connections.

Actual Results:  The client tries to connect to the server. It actually does
generate some TCP traffic, but never manages to connect to either an IMAP or
NNTP server. It eventually seems to time out and stop, but doesn't generate an
error or other user feedback, much like if you'd clicked on stop yourself.

As I said above, it worked in 2002021510. As a side note, outgoing mail
connections to SMTP servers do not seem to be affected by this.
CC Bradley who added the socks mailnew feature
Doh, I meant to attach that patch onto this bug. Oh well...

Dupe of 128045

*** This bug has been marked as a duplicate of 128045 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
*** Bug 128234 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: huang → stephend
verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.