Mozilla fails to render page body style (background color)

RESOLVED FIXED

Status

()

Core
Layout: HTML Frames
P2
major
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Christopher Cook, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
See attached test case. Open index.htm, the page should render with a left hand
frame, dark background, some menu items. right frame is a white page. Move the
mouse over the bottom link of the left hand frame. left hand frame becomes half
white/half dark (rendering of background colour stops where the content stops
rather than filling the frame). spooky. I'd be perfectly happy if it turned out
I was doing something wrong but the page renders fine in IE5.5 and I have seen
this type of bug in mozilla before but that was fixed years ago (literally)..
(Reporter)

Comment 1

16 years ago
Created attachment 71676 [details]
Page rendering testcase 

Unzip the testcase and open index.htm, move over the left hand links, page
background color half-disappears for me..
(Reporter)

Comment 2

16 years ago
By the way, attached testcase is a zip file so you may have to save it as .zip
(comes up as attachment.cgi for me..)
(Reporter)

Comment 3

16 years ago
Ah, more specific perhaps, save this snippet of css as styles.css, replacing the
existing copy, it shows that changing font family on hover is the part that
causes the problem, changing text-decoration etc works fine, changing font on
link hover causes the backround rendering glitch:

.bodyStyle1 {
	background-color : #C0C0C0;
}

a.lightlink:hover {
	font-family : Arial;
}

Comment 4

16 years ago
seems like ... ugh ...  a dup of bug 63863 ...
Maybe related to bug 88154 instead?
(Reporter)

Comment 6

16 years ago
Quite possibly related to all sorts of other bugs as the problem also occurs in
builds as old as 2001-12-21-06.

Comment 7

16 years ago
I have the same problem with www.ondelette.com. Go to left menu. As you go over
the links, the "mouseover" effect changes the background color to white from blue.

Really scary stuff.

Comment 8

16 years ago
Please move this bug from unconfirmed to new since anyone can easily reproduce
the effect.

Comment 9

16 years ago
This is a scrolling="no" issue on the left frame. Changing it to "auto" will
resolve this problem. Changing component to HTML Frames
Assignee: attinasi → jkeiser
Status: UNCONFIRMED → NEW
Component: Layout → HTMLFrames
Ever confirmed: true
QA Contact: petersen → amar

Updated

16 years ago
Priority: -- → P2

Comment 10

16 years ago
Thanks for the woraround. Indeed, it fixes the problem on ondelette.com. The
background doesn't change anymore under Mozilla.

Thanks for switching the bug to "NEW".
(Reporter)

Comment 11

16 years ago
The prescribed workaround works for the testcase too, setting scrolling="no" to
scrolling="auto" or scrolling="yes" lets the page function normally.
(Assignee)

Updated

16 years ago
Blocks: 124431
(Assignee)

Comment 12

16 years ago
This testcase crashes when I try to load it now.  But it sounds *so* much like
the other scrolling="no" problems that I can't believe it won't be fixed with
119849.
Depends on: 119849
(Assignee)

Updated

16 years ago
Attachment #71676 - Attachment mime type: application/octet-stream → text/html
(Assignee)

Updated

16 years ago
Attachment #71676 - Attachment mime type: text/html → application/octet-stream
(Assignee)

Comment 13

16 years ago
Not crashing anymore, and fixed with bug 119849.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.