HTML5 video playing with lag at fullscreen mode

RESOLVED DUPLICATE of bug 1210726

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1210726
3 years ago
2 months ago

People

(Reporter: jaumet, Unassigned)

Tracking

(Depends on 1 bug, {regression})

47 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160607080223

Steps to reproduce:

Watching some html5 videos in fullscreen mode (especially youtube) both vp9 and h.264 format.
Intel broadwell graphics at Linux 4.6.2 and mesa 11.2.2.


Actual results:

The video has lag problems(sound still plays correctly) when the video is in fullscreen mode.


Expected results:

Video playing smoothly
Summary: fullscreen video html5 lag → HTML5 video playing with lag at fullscreen mode
I am able to reproduce this issue on 

Version 	50.0a1
Build ID 	20160621030208
User Agent 	Mozilla/5.0 (X11; Linux i686; rv:50.0) Gecko/20100101 Firefox/50.0

I observe lagging in regular mode too.
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Is this a regression?

I've only found performance problematic on Atom-level CPUs and has started improving from 48. What CPU do you have?

We use the CPU to decode/render on Linux. Setting layers.acceleration.force-enabled=true in about:config should improve performance but it is not without issues. See bug 594876. Accelerated layers on Linux is a work in progress.
Flags: needinfo?(retrasado.man)
I have i5-5200U, intel HD graphics 5500. I've reported this issue because before 47 release update i didn't expected lag problems on any html5 video.
Can you see if it is better in 48?
Keywords: regression
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #4)
> Can you see if it is better in 48?

When update 48 arrives I will report more feedback.
I have tried with Gnome under Wayland and the problem seems to disapear, maybe the problem is related with xf86-video-intel driver
(In reply to Jaume from comment #6)
> I have tried with Gnome under Wayland and the problem seems to disapear,
> maybe the problem is related with xf86-video-intel driver

Perhaps. Is 48 any better?
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #7)
> Perhaps. Is 48 any better?

No, it is still lagging but I think it is a problem from the kernel and the X window driver.
Flags: needinfo?(jaumet)
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210726
You need to log in before you can comment on or make changes to this bug.