bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.
RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160618030212

Steps to reproduce:

1. Create fresh profile
2. Go to http://bl.ocks.org/mbostock/6224050


Actual results:

Nothing happens. Nothing loads in the box


Expected results:

it should have loaded.
Chrome can display this page.
(Reporter)

Comment 1

2 years ago
I meant:  the page loads, but the box in the page doesnt load. No content appears in the box.
Works for me on mac 50.0a1 (2016-06-18).  What platform were you testing on?  Can you paste your about:support info here?
Flags: needinfo?(mayankleoboy1)

Comment 3

2 years ago
How strange. It didn't load for me (d3 is undefined). The contents of the frame loaded fine in it own tab. I spent some time trying to figure out if the iframe sandbox policy is supposed to block different-origin javascript and eventually gave up.

Now I open it again and it loaded fine...
(Reporter)

Comment 4

2 years ago
Created attachment 8763352 [details]
aboutsupport.txt

Win10x64.
64 bit nightly.

I get this in console:

An iframe which has both allow-scripts and allow-same-origin for its sandbox attribute can remove its sandboxing.6224050
ReferenceError: d3 is not defined
bestCircleGenerator()
656c1553842daab8ff38471beb4a3fa31a13759a:56
<anonymous>
656c1553842daab8ff38471beb4a3fa31a13759a:29
[Learn More]656c1553842daab8ff38471beb4a3fa31a13759a:56:7
ReferenceError: d3 is not defined
<anonymous>
6224050:57

All the examples/demos on his site dont load.
[Learn More]
Flags: needinfo?(mayankleoboy1)
Boris, do you see anything unusual with the sandboxed iframes here?

I'm at a conference next couple of days and won't be able to follow-up here.
Flags: needinfo?(bzbarsky)
If you open the network panel in sections, do you see d3.js loading successfully?
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 7

2 years ago
Created attachment 8763354 [details]
bug.png

not sure how to do check what you said.
Hopefully this attachment is enough.
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 8

2 years ago
OK, I think it might be related to my ISP. 

When i use Nightly to open the URL, I get a Cloudflare Warning page, which asks me to solve some captcha. After I solve it, I am redirected to the original URL. But it loads nothing.

When I use Chrome, I get the same treatment.

But when I use Chrome, with Datasaver extension enabled ( which compresses data through Google servers, and I think it gives a proxy of USA. I dont live in USA), I get the page staightforward, and the content loads.

URL of datasaver : https://chrome.google.com/webstore/detail/data-saver/pfmgfdlgomnbgkofeojodiodmgpgmkac?utm_source=chrome-app-launcher-info-dialog
Created attachment 8763355 [details]
d3js-screenshot.png

Yea, thats exactly what I meant.  Thanks!

This is what it should look like when it works.  The only difference I see in the request headers is that I have a cookie.  I verified, though, that it still works in a private browsing window without that cookie, so I don't think its related.

It seems like maybe you have a bad web proxy between you and d3js.org somewhere.  Can you see if this reproduces from other network locations?
Flags: needinfo?(bzbarsky)

Comment 10

2 years ago
Here's what I see: every time I close and reopen nightly, that iframe doesn't work. No attempt is made to load d3js.org/d3.v3.min.js according to networking page. Opening the iframe in its own tab also does not work and d3js.org/d3.v3.min.js is not mentioned on the networking page.

But every time if I manually load the d3js.org/d3.v3.min.js in its own tab, then from now on the page loads d3js.org/d3.v3.min.js and works just fine. I can then close nightly, open it again, and the borkage starts again.
(Reporter)

Comment 11

2 years ago
> It seems like maybe you have a bad web proxy between you and d3js.org
> somewhere.  Can you see if this reproduces from other network locations?

Wont be able to check from other locations, sorry.

Comment 12

2 years ago
(In reply to Radek 'sysKin' Czyz from comment #10)
> Here's what I see

Ugh, sorry, ignore me -- this was NoScript. It's still a strange and inconsistent behaviour but caused by NoScript. Ignore me ~
Ah, no problem!  Thanks for the report.  I'm glad we were able to figure it out.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 14

2 years ago
(In reply to Ben Kelly [:bkelly] from comment #13)
> Ah, no problem!  Thanks for the report.  I'm glad we were able to figure it
> out.

You sure this is not a real bug in nightly?
Oh, I'm sorry.  I didn't see the noscript report was from a different person.

Do you have any addons?  Can you try running in safe mode and see if it reproduces?

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(mayankleoboy1)
Resolution: INVALID → ---
(Reporter)

Comment 16

2 years ago
i tried in a new profile, as said in the first comment. The about:support is from my normal profile. Is that sufficient enough?

(You might want to rest a bit after London. This bug can wait :) )
Alright.  I guess we need to see if anyone else can reproduce in a fresh profile.
Flags: needinfo?(mayankleoboy1)
So at this point, we have two reports here, right?

1) Radek.  In his case, the issue is noscript.
2) mayankleoboy1 (original reporter).  In this case, the behavior is the same in
   Firefox and Chrome; in both cases the site is attempting to do catpcha stuff
   which of course isn't going to do any good for a subresource load.  This
   makes it somewhat unlikely that this is a problem in Firefox per se....

One thing I did want to check: in Chrome, does the original page also not work?  Because it really does sound like this is some weird interaction between cloudflare and the originating point of the request (the ISP or the IP address block or something)...
Tested on Windows 10 x64 FF Nightly 50.0a1(2016-07-25)
Tested on Mac OS X 10.10 with FF 47 and 50.0a1 (2016-07-25) with new profile and I can't reproduce this issue. 
Mayankleoboy1 do you still see this issue?
Flags: needinfo?(mayankleoboy1)
(Reporter)

Comment 20

2 years ago
Yes this loads perfectly now.
And the problem with my ISP is also fixed.

Please close this bug appropriately.
(Reporter)

Updated

2 years ago
Flags: needinfo?(mayankleoboy1)
Thanks for feedback.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.