Closed Bug 128081 Opened 22 years ago Closed 21 years ago

Internet Keywords - brandless implementation (pick a new default server)

Categories

(SeaMonkey :: Location Bar, defect)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benc, Assigned: samir_bugzilla)

References

Details

IK is a good idea, probably one that needs fixing. I don't think (per bug
76547), we will ever decide it should be removed.

However bug 14532 suggest that we should be abstracting the Netscape brand from
the  Mozilla build.

IK is already off by default in mozilla builds (bug 100412), which may be enough
for most people.

Gerv has fixed the "More Info" button, and provided some Mozilla text, there is
also a really improved page that will arrive in the next week. Both pages are
completely mozilla oriented.

The default pref, however, remains "http://keyword.netscape.com". If we want to
change this, this is the time and place to decide.

Someday, networking will not care about contributor testing of DNS (someday we
will have a full DNS test suite...), so this is a real question, because someday
Networking will recommend that mozilla set IK on by default again...
Ben, this looks like it could go to either Networking or Search rather than
General. What do you think?
This is actually a feature owned by someone... If you query for all bugs (of any
status), IK shows up in several places.

Personally, I think it goes to Search, because it is not a Networking feature.
If you have a problem with the keyword: handler, that *might* be Networking.

The only reason I got involved is that people type stuff, then blame necko for
not getting at sensible result.
Assignee: asa → sgehani
Component: Browser-General → Search
QA Contact: doron → claudius
-> URL bar, that is where the other IK bugs are.

Also as a note, Phoenix has decided to use Google's you got lucky.

http://www.mozilla.org/docs/end-user/internet-keywords.html
Component: Search → URL Bar
*** Bug 190139 has been marked as a duplicate of this bug. ***
Fixed in bug 225490, but that bug should have been dependent on this bug, and
fixed here.
Blocks: 225490
Severity: trivial → critical
RESOLVED/fixed.
(benb will be so happy)
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.