Console mishandles either bound or self-hosted functions, unclear which

RESOLVED DUPLICATE of bug 1280818

Status

()

Firefox
Developer Tools: Console
RESOLVED DUPLICATE of bug 1280818
a year ago
a year ago

People

(Reporter: bz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Testcase:

  <script>
  var log = console.log.bind(console);
  log("a");
  </script>

This comes up in the console with a location of "(unknown)".

For extra badness, doing this:

  <script>
  function f() {
    var trace = console.log.bind(console);
    trace();
  }
  f();
  </script>

shows not only a location of "(unknown)" but also an empty stacktrace.
Is this a duplicate of Bug 1280818?
Flags: needinfo?(bzbarsky)
Yes, I thought I'd marked it so....
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bzbarsky)
Resolution: --- → DUPLICATE
Duplicate of bug: 1280818
You need to log in before you can comment on or make changes to this bug.