WebExtensions: chrome.windows.create does not complete if negative values for 'left' and 'top' positions

RESOLVED DUPLICATE of bug 1279562

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1279562
2 years ago
2 years ago

People

(Reporter: dw-dev, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

This is problem is related to Bug 1279562.

I tried executing the following code:

    chrome.windows.create({ type: "normal", left: -8, top: -8, width: (1920+8+8), height: (1080+8+8) },
    function(win)
    {
        .....
        .....
    });




Actual results:

chrome.windows.create() failed with the following message in the console:

    "Type error for parameter createData (Error processing left:
     Integer -8 is too small (must be at least 0)) for windows.create."

chrome.windows.create() does not create a window.

Further testing showed that chrome.windows.create() always fails if the 'left' or 'top' parameters are negative.  





Expected results:

The behaviour in Firefox is incompatible with the behaviour in Chrome.

Chrome displays the window using '0' values for 'left' and/or 'top', instead of negative values.

The behaviour in Firefox should be the same as in in Chrome.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1279562
(Reporter)

Comment 2

2 years ago
My understanding is that Bug 1279562 fixes the reported problem with negative 'left' and 'top' parameters in chrome.windows.update().

I was not aware that Bug 1279562 fixes this problem with negative 'left' and 'top' parameters in chrome.windows.create().

Does Bug 1279562 fix both problems?
Flags: needinfo?(kmaglione+bmo)
Yes, it fixes both problems.
Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.