Crash sorting on Name or Email in Address book if a card is displayed in Card View

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
critical
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: esther, Assigned: chuang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using M10 builds 1999082712 on Win95, 1999082705 on linux and 1999082712 on mac
sorting in the results pane of address book will crash if you have clicked on a
card and displayed it in the Card View pane.  Note: I not only do I crash, but I
have to reboot my system to get Messenger to run again.  If I try to launch
Messenger without rebooting, it hangs up here:
profile = [xpconnect wrapped nsIProfileServices]
Adding element 0 : 827
************** In showSelection routine!!!!!!!!!
num: 0
name: 827
************Inside Start Communicator prof
************name: 827
Created nsToolkitCore
Profile Manager : Profile Wizard and Manager activites : End

Steps:

1. Launch Messenger
2. Launch Address Book usng Tasks Address Book
3. Click on Personal Address Book (you should see a list of your card in Results
pane, if you don't you have to create some cards using New Card toolbar button).
4. Click on one of the cards (card should display in the Card View pane.
5. Click on the Name or Email header of the Results pane to sort the cards.
Crash.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → esther
(Assignee)

Comment 1

19 years ago
I can't reporduce on my NT with my debug build. I have 4 or 5 cards on my
address books.  I followed the steps to step5, it didn't crash, the selection in
result pane is gone and the card view pane shows nothing.
(Reporter)

Comment 2

19 years ago
I will try with the 8/30 builds (today's), and then update with results.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

19 years ago
Can't reproduce on Linux and mac on 8/30 builds, Had Suresh try on win32 (since
I can't get the 8/30 build to laucnch on my system) and it was OK for him. I
will resolve as worksforme and verify.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.