Discussion Forum: mozilla.apis

RESOLVED FIXED

Status

Infrastructure & Operations
MOC: Service Requests
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: pmoore, Assigned: Usul)

Tracking

Details

(Whiteboard: [Waiting on Google], URL)

(Reporter)

Description

a year ago
List Name: mozilla.apis
List Admin: pmoore@mozilla.com

Short Description:
A uniform interface of mozilla's platform APIs

Long Description:
An initiative to provide a centralised definition of the APIs that mozilla exposes to its users. This includes services such as Treeherder, TaskCluster, Bugzilla, RelEngAPI, and others. The aim of this project is to provide a service where API schemas can be submitted, that will enable teams to develop APIs independently, yet have them registered centrally in a global catalogue. Ultimately it is our desire to be able to auto-generate a command line interface and language libraries based on the ingested schemas, such that all tools can benefit from a shared interface, be it command line, online docs, or through language-specific client libraries. See https://wiki.mozilla.org/Platforms_Operations/APIs

Justification / Special Instructions:
Over to I&O.

Gerv
Assignee: gerv → nobody
Component: Discussion Forums → MOC: Service Requests
Product: mozilla.org → Infrastructure & Operations
QA Contact: justdave → lypulong
(Assignee)

Updated

a year ago
Assignee: nobody → ludovic
(Assignee)

Updated

a year ago
Whiteboard: [waiting for Giganews and Google]
(Assignee)

Updated

a year ago
Whiteboard: [waiting for Giganews and Google] → [Waiting on Google]
(Assignee)

Comment 2

a year ago
newsgroup has been created , set to advertized. wiating for google to pick it up.
(Reporter)

Comment 3

a year ago
(In reply to Ludovic Hirlimann [:Usul] from comment #2)
> newsgroup has been created , set to advertized. wiating for google to pick
> it up.

Many thanks!
(Reporter)

Comment 4

a year ago
The new list appears as "mozilla-apis" in https://lists.mozilla.org/listinfo but other lists on the page are not prefixed "mozilla-" - should this just be "apis" instead for consistency?
Flags: needinfo?(ludovic)
(Assignee)

Comment 5

a year ago
(In reply to Pete Moore [:pmoore][:pete] from comment #4)
> The new list appears as "mozilla-apis" in https://lists.mozilla.org/listinfo
> but other lists on the page are not prefixed "mozilla-" - should this just
> be "apis" instead for consistency?

I don't know how that page is created. I've followed standard procedures here so , no clue.
Flags: needinfo?(ludovic)
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Usul: something does seem to have gone wrong here if the list name is not of the standard form (i.e. without the "mozilla")? Can we see these procedures you are following?

I suspect if the list is not correctly named, some of the plumbing which connects up the Google Group, list and newsgroup will not work...

Gerv
Flags: needinfo?(ludovic)
Ludo is on paternity leave.
The procedure is at https://mana.mozilla.org/wiki/display/SYSADMIN/Newsgroups

The list and newsgroup are connected by configuration on the mailman server which should have nothing to do with the name of the mailman list itself. It's just a convention.

We can rename the mailman list (actually remove the old list and create a new one. It's not possible to simply rename a mailman list) if it's a problem.
Flags: needinfo?(ludovic)
Congratulations, Ludo!

Yes, please fix the list name, because the autogenerated HTML here:
https://www.mozilla.org/about/forums/
relies on the standard relationship between the names of all the components, so if you don't fix, it the "mailing list" link will be wrong.

There have been no messages except my test ones, so fixing it won't lose data.

Gerv
Flags: needinfo?(pradcliffe+bugzilla)
(Reporter)

Comment 9

a year ago
Thanks guys for following up on this. :-)
[root@mailman2.mail.scl3 bin]# ./rmlist -a mozilla-apis
Removing list info
Removing private archives
Removing private archives
Removing public archives
mozilla-apis public archives not found as /var/lib/mailman/archives/public/mozilla-apis.mbox

[root@mailman2.mail.scl3 bin]# ./newlist apis pmoore@mozilla.com
Initial apis password: 
Hit enter to notify apis owner...

[root@mailman2.mail.scl3 bin]# ./list_lists | grep -i apis
                               Apis - [no description available]
[root@mailman2.mail.scl3 bin]# sudo -i postalias /etc/mailman/aliases
[root@mailman2.mail.scl3 bin]# sudo -i newaliases

Changes made in web interface.

[root@mailman2.mail.scl3 bin]# ./list_lists | grep -i apis
                               apis - A uniform interface of mozilla's platform APIs


Should now be set, if you could do some new test messages to confirm.
Flags: needinfo?(pradcliffe+bugzilla)
I can confirm this is all now working correctly, in all directions. :-) Thanks, Peter.

Gerv
(Reporter)

Comment 12

a year ago
Wonderful, many thanks Gerv, Peter.
You need to log in before you can comment on or make changes to this bug.