Inconsistent download protection allow download message

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 affected, firefox49 affected, firefox50 affected)

Details

Attachments

(1 attachment)

Created attachment 8763900 [details]
Screenshot showing the issue

[Affected versions]:
- Firefox 48 beta 2
- latest Developer Edition 49.0a2
- latest Nightly 50.0a1

[Affected platforms]:
- Mac OS X 10.10.5
- Ubuntu 16.04 32-bit
- Windows 10 64-bit

[Steps to reproduce]:
1. Start Firefox with clean profile
2. Visit http://testsafebrowsing.appspot.com/
3. Click on any item from 5 to 7.
4. Save file
5. Click Magnifying glass or Folder icon
6. Hit cancel
7. Click on Download icon
8. Right click item and select Allow Download

[Expected result]:
- Same dialog appears for both scenarios

[Actual result]:
- Same dialog appears but on step 5 there is an extra button to remove file appears when clicking Magnifying glass or Folder icons.

[Regression range]:
- Don't know if this is a regression, will investigate further ASAP.

[Additional notes]:
- Screencast showing the issue attached.

Comment 1

2 years ago
It's by design. The tooltip on the magnifying glass or folder icons should have a message indicating which choice will be asked.
Resolving this per comment 1.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.