Version number incorrectly shows as 38.8.0

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
--
minor
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Stefano, Unassigned, NeedInfo)

Tracking

42 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160609214634

Steps to reproduce:

In linux 64bit:
open terminal and type:
thunderbird -version


Actual results:

this is the result:
(process:15579): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
 Thunderbird 38.8.0


Expected results:

There are two problems:
1) The assertion-error with Glib
2) version number is NOT correct (in fact the correct version is 47.0b2)
(Reporter)

Updated

a year ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

a year ago
At least on trunk it says

Thunderbird 50.0a1
38.8.0 on windows.  thunderbird.exe -version  correctly displays 38.8.0 for me


> 2) version number is NOT correct (in fact the correct version is 47.0b2)

so when you start thunderbird and visit help | about it shows 47.0b2?  
(which just came out)
Severity: normal → minor
Flags: needinfo?(konnorit)
Summary: Version number not updated → Version number shows as
also, from where did you download Thunderbird?
Summary: Version number shows as → Version number incorrectly shows as 38.8.0
(Reporter)

Comment 4

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #2)
> 38.8.0 on windows.  thunderbird.exe -version  correctly displays 38.8.0 for
> me
> 
> 
> > 2) version number is NOT correct (in fact the correct version is 47.0b2)
> 
> so when you start thunderbird and visit help | about it shows 47.0b2?  
> (which just came out)

Yeah! It show 47.0, but in terminal it show 38.8.0.

(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #3)
> also, from where did you download Thunderbird?

I have downloaded it from mozilla ftp (https://ftp.mozilla.org/pub/thunderbird/releases/47.0b2/linux-x86_64/it/).
Chris, what do you make of this?
Flags: needinfo?(chris.ramsden)
(Reporter)

Updated

a year ago
Flags: needinfo?(konnorit)
(Reporter)

Comment 6

a year ago
I can't see any reply! :-(
Leho, does this reproduce for you?
Flags: needinfo?(chris.ramsden) → needinfo?(leho)

Comment 8

a year ago
I see something odd in that I install TB manually into /opt yet 'which' and similar cli commands to query the the location of a program incorrectly (IMHO) report /usr/lib or similar. 

I haven't investigated /user/lib to see if there is an unused installation of Thunderbird there, but I would ask the OP if he is confident about precisely which executable is being invoked when he types "thunderbird" at the cli.

Comment 9

a year ago
(In reply to Chris Ramsden from comment #8)
> I see something odd in that I install TB manually into /opt yet 'which' and
> similar cli commands to query the the location of a program incorrectly
> (IMHO) report /usr/lib or similar. 
> 
> I haven't investigated /user/lib to see if there is an unused installation
> of Thunderbird there, but I would ask the OP if he is confident about
> precisely which executable is being invoked when he types "thunderbird" at
> the cli.

Here in W7, I get no response at all to running Thunderbird in this way from the command line: 

C:\Program Files (x86)\Mozilla Thunderbird>thunderbird.exe -version

C:\Program Files (x86)\Mozilla Thunderbird>
(In reply to Chris Ramsden from comment #9)
> (In reply to Chris Ramsden from comment #8)
> > I see something odd in that I install TB manually into /opt yet 'which' and
> > similar cli commands to query the the location of a program incorrectly
> > (IMHO) report /usr/lib or similar. 
> > 
> > I haven't investigated /user/lib to see if there is an unused installation
> > of Thunderbird there, but I would ask the OP if he is confident about
> > precisely which executable is being invoked when he types "thunderbird" at
> > the cli.
> 
> Here in W7, I get no response at all to running Thunderbird in this way from
> the command line: 
> 
> C:\Program Files (x86)\Mozilla Thunderbird>thunderbird.exe -version

yeah, on windows CLI output is slightly broken.  To see the output you must pipe it to "more".
  thunderbird.exe -version | more
(Reporter)

Comment 11

a year ago
Created attachment 8778918 [details]
Schermata del 2016-08-08 16:47:59.png
(Reporter)

Comment 12

a year ago
there is the same prob in the new TB beta version (see attached file!)

Comment 13

a year ago
Created attachment 8778925 [details]
version numbers, GUI vs terminal, W7

Can't reproduce that here on W7.
Are you sure you're running the same executable in both cases? Typing "thunderbird" on the command line might be finding your distro's version of Thunderbird, not the beta you downloaded.
(Reporter)

Comment 15

a year ago
(In reply to Jim Porter (:squib) from comment #14)
> Are you sure you're running the same executable in both cases? Typing
> "thunderbird" on the command line might be finding your distro's version of
> Thunderbird, not the beta you downloaded.

Oh my god! Yes, you are right Jim! In fact if I type /opt/thunderbird/thunderbird -version I get the correct version number (47.0).

I am sorry, for me you can close this bug.

Thank you!

Stefano

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.