Crash in OOM | unknown | js::AutoEnterOOMUnsafeRegion::crash | js::gc::GCRuntime::beginSweepingZoneGroup

RESOLVED DUPLICATE of bug 1280132

Status

()

Core
JavaScript: GC
--
critical
RESOLVED DUPLICATE of bug 1280132
a year ago
a year ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

48 Branch
x86
Windows 10
crash
Points:
---

Firefox Tracking Flags

(firefox48- affected, firefox49 affected, firefox50 affected)

Details

(crash signature)

(Reporter)

Description

a year ago
[Tracking Requested - why for this release]: Another new JS crash that we may want to keep an eye on.

This bug was filed from the Socorro interface and is 
report bp-07df96d1-dd31-4565-b305-9b2232160614.
=============================================================

Seen while looking at Beta crash stats. Link to crashes: http://bit.ly/28KM2L2

Frame 	Module 	Signature 	Source
0 	xul.dll 	js::AutoEnterOOMUnsafeRegion::crash(char const*) 	js/src/jscntxt.cpp:1236
1 	xul.dll 	js::gc::GCRuntime::beginSweepingZoneGroup() 	js/src/jsgc.cpp:5215
2 	xul.dll 	js::detail::OrderedHashTable<js::OrderedHashMap<JS::GCCellPtr, mozilla::Vector<js::gc::WeakMarkable, 2, js::SystemAllocPolicy>, js::gc::WeakKeyTableHashPolicy, js::SystemAllocPolicy>::Entry, js::OrderedHashMap<JS::GCCellPtr, mozilla::Vector<js::gc::WeakMarkable, 2, js::SystemAllocPolicy>, js::gc::WeakKeyTableHashPolicy, js::SystemAllocPolicy>::MapOps, js::SystemAllocPolicy>::freeData(js::detail::OrderedHashTable<js::OrderedHashMap<JS::GCCellPtr, mozilla::Vector<js::gc::WeakMarkable, 2, js::SystemAllocPolicy>, js::gc::WeakKeyTableHashPolicy, js::SystemAllocPolicy>::Entry, js::OrderedHashMap<JS::GCCellPtr, mozilla::Vector<js::gc::WeakMarkable, 2, js::SystemAllocPolicy>, js::gc::WeakKeyTableHashPolicy, js::SystemAllocPolicy>::MapOps, js::SystemAllocPolicy>::Data*, unsigned int) 	js/src/ds/OrderedHashTable.h:576
3 	xul.dll 	js::detail::OrderedHashTable<js::OrderedHashMap<JS::GCCellPtr, mozilla::Vector<js::gc::WeakMarkable, 2, js::SystemAllocPolicy>, js::gc::WeakKeyTableHashPolicy, js::SystemAllocPolicy>::Entry, js::OrderedHashMap<JS::GCCellPtr, mozilla::Vector<js::gc::WeakMarkable, 2, js::SystemAllocPolicy>, js::gc::WeakKeyTableHashPolicy, js::SystemAllocPolicy>::MapOps, js::SystemAllocPolicy>::rehash(unsigned int) 	js/src/ds/OrderedHashTable.h:666
4 	xul.dll 	xul.dll@0x1ebd773 	
5 		@0x8557fdf 	
6 	xul.dll 	mozilla::dom::Geolocation::~Geolocation() 	dom/geolocation/nsGeolocation.cpp:1249
7 	ntdll.dll 	RtlGetSystemTimePrecise 	
8 	xul.dll 	js::gcstats::AutoPhase::~AutoPhase() 	js/src/gc/Statistics.h:408
9 	xul.dll 	js::gc::GCRuntime::endMarkingZoneGroup() 	js/src/jsgc.cpp:5047
10 	xul.dll 	js::gc::GCRuntime::sweepPhase(js::SliceBudget&) 	js/src/jsgc.cpp:5625
11 	xul.dll 	js::gc::GCRuntime::incrementalCollectSlice(js::SliceBudget&, JS::gcreason::Reason) 	js/src/jsgc.cpp:6189
12 	xul.dll 	js::gc::GCRuntime::gcCycle(bool, js::SliceBudget&, JS::gcreason::Reason) 	js/src/jsgc.cpp:6412
13 	xul.dll 	js::gc::GCRuntime::collect(bool, js::SliceBudget, JS::gcreason::Reason) 	js/src/jsgc.cpp:6520
14 	xul.dll 	js::gc::GCRuntime::gcSlice(JS::gcreason::Reason, __int64) 	js/src/jsgc.cpp:6595
15 	xul.dll 	js::gc::GCRuntime::notifyDidPaint() 	js/src/jsgc.cpp:6654
16 	xul.dll 	mozilla::RefreshDriverTimer::TickRefreshDrivers(__int64, mozilla::TimeStamp, nsTArray<RefPtr<nsRefreshDriver> >&) 	layout/base/nsRefreshDriver.cpp:246
17 	xul.dll 	mozilla::BaseTimeDuration<mozilla::TimeDurationValueCalculator>::FromMilliseconds(double) 	obj-firefox/dist/include/mozilla/TimeStamp.h:132
This appears to be identical to bug 1280132; I'm not sure why it's being binned differently.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1280132
tracking-firefox48: ? → -
You need to log in before you can comment on or make changes to this bug.