chrome.extension.getURL is not returning the same URL

RESOLVED DUPLICATE of bug 1257989

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1257989
2 years ago
2 years ago

People

(Reporter: Harsha A, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/601.6.17 (KHTML, like Gecko) Version/9.1.1 Safari/601.6.17

Steps to reproduce:

1) Install Firefox Addon build with WebExtensiosn 
2) In Console (while debugging) called chrome.extension.getURL("")
3) Returns some url of type moz-extension://<guid> 
4) Quit your browser. Delete all profiles 
5) Restart the browser and repeat steps 1 and 2.



Actual results:

The results on chrome.extension.getURL() are not consistent and same. Different URLs are returned.


Expected results:

Same URL should be returned. 

In Chrome calling chrome.extension.getURL() returns the same URL for the extension. 

This allows us to whitelist part of the extension URL so our webpages can pass some sensitive information directly to the extension.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → WebExtensions
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 1257989
You need to log in before you can comment on or make changes to this bug.