New findbar highlighting is a huge regression for me

RESOLVED INVALID

Status

()

Toolkit
Find Toolbar
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: billm, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

I'm having a lot of problems with the new findbar highlighting.

1. The worst aspect is that it covers up the characters to the left and right of what was found. For example, if I search for "bc" in a page containing "abcd", then "a" and "d" are covered up by the yellow box.

2. Searching just feels slower to me now. I'm very accustomed to searching throw source code listings. Now I wince whenever I have to do it because I know I'm going to get a lot of jank.

3. For some reason, all the other results in the page are shown in white. Maybe this is intentional, but it just looks buggy and and unprofessional.

4. When I search for a word, there's a slight delay after I stop typing and then the found word pulses a second time. This is also probably intentional, but it definitely makes the impression of jank much worse. My brain thinks that it actually took that long to do the search, rather than it being an intentional delay. Also, to make matters worse, the white background around other results in the page is not updated until the second pulse.

5. When search results are highlighted, scrolling (with the up/down keys) is extremely jerky. This might be better if I weren't using Linux, but it's still really bad.

In general I like the idea of doing a better job with highlighting. But I think the current implementation needs a lot more work. It's really ruining nightly for me, and I think it should be backed out until these issues can be fixed.
Also:

6. "Find Next" is much slower now.
Another problem:

7. Go to a page, navigate somewhere, then go back. Now search for a term on the page and go forward again. When you go back, the highlight for the search will still be there. Even if you close the findbar, it will still be there.
It looks like you can disable the new behavior by setting findbar.modalHighlight and findbar.highlightAll to false.
(In reply to Bill McCloskey (:billm) from comment #0)
> In general I like the idea of doing a better job with highlighting. But I
> think the current implementation needs a lot more work. It's really ruining
> nightly for me, and I think it should be backed out until these issues can
> be fixed.

This is all very good feedback. Bug 1281462 has been filed to turn off the new find-in-page until the implementation is improved.
Do you know what's going on here Jared? This is back in Nightly and none of the problems I reported seem to have been fixed. In addition, text is now being rendered incorrectly.
Flags: needinfo?(jaws)
All I can say at the moment is that there's a slew of updates coming that will make the experience a lot better. 

1) This is bug 1302029.
2) :mstange is looking at performance and that's looking very promising in bug 1302551.
3) :mstange is again working this out in bug 1302551 to make the rectangles fully transparent again. It was supposed to be like that from the start, but mistakenly ended up like this.
4) Bug 1302522 will remove the transitions and only a *boink* animation will remain that plays at 60fps at least.
5) Again, bug 1302551.
6) Well, it might be better for you already, but with more speed from bug 1302551, it'll be just fine.
7) This should be fixed and not happen anymore - certainly not in the next Nightly.

As you can see, this feature - and TBH most others too - will benefit greatly from a platform engineer who's rising to the occasion and together we'll be making it awesome. Makes me grateful and humble.
Now that doesn't mean all bugs are gone! Please keep 'em coming, I'll dupe if applicable.

Thanks for your feedback - I hope you'll be a happy user in a few days from now.
Flags: needinfo?(jaws)
(In reply to Bill McCloskey (:billm) from comment #5)
> Do you know what's going on here Jared? This is back in Nightly and none of
> the problems I reported seem to have been fixed. In addition, text is now
> being rendered incorrectly.

Sorry that this bug wasn't updated Bill. As Mike commented, each of the issues you've mentioned is being tracked already and most are being worked on.

I think the reason this bug went unnoticed was because the majority of the new modal highlighting related bugs are being filed against bug 1291278 and bug 384458.

Are you OK with me closing this bug since it's somewhat turned in to a metabug/duplicate?
Flags: needinfo?(wmccloskey)
Yes, thanks for the info.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(wmccloskey)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.