table row can not be re-displayed

RESOLVED DUPLICATE of bug 125701

Status

()

Core
Layout
P4
normal
RESOLVED DUPLICATE of bug 125701
16 years ago
16 years ago

People

(Reporter: Kevin Cook, Assigned: Marc Attinasi)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When a table row has been set to "display:none," it cannot be rendered visible
again, by applying "display:block"

Clicking on "blah" on the sample page hides the table row above it.  Clicking it
a second time should re-display it, but does not. (sample at
http://www.priss.org/mozbug/display_bug.htm)
Over to layout... Note that the correct display value for table rows is
"table-row", not "block".  See
http://www.w3.org/TR/REC-CSS2/visuren.html#display-prop
Assignee: jst → attinasi
Component: DOM Core → Layout
OS: Windows 98 → All
QA Contact: stummala → petersen
Hardware: PC → All
(Reporter)

Comment 2

16 years ago
Hmmm.... Does CSS2 (support for "display:table-row") necessitate that
"display:block" (CSS1) have no effect whatsoever on a table row?  I hadn't
thought of that.

Comment 3

16 years ago
Confirming in the March 01 build (2002-03-01-03) under OS X .
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4

Updated

16 years ago
Target Milestone: --- → Future

*** This bug has been marked as a duplicate of 125701 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.