Cannot delete flexible space in Customize menu after after upgrading to Firefox 47.0

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: xircal, Unassigned)

Tracking

47 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8764214 [details]
cannot_delete_flex-space_customize_menu.PNG

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

After upgrading to Firefox 47.0 and rearranging buttons in the Customize menu after adding the "No Squint Plus" extension, flexible spaces can be added, but not moved or deleted. 

This bug can't be tested in a new profile since the flexible space button is missing altogether in the Customize menu. 


Actual results:

Flexible spaces appear to be disabled when trying to move them and the whole page moves instead. Similarly, they can't be deleted either. 


Expected results:

Flexible spaces should behave the same way as other buttons.
(Reporter)

Updated

2 years ago
Component: Untriaged → Toolbars and Customization
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
Created attachment 8764216 [details]
Flexible space button missing in new profile

This screenshot illustrates the missing flexible space button problem in a new profile.

Comment 2

2 years ago
You can't add flexible spaces at all in Firefox. The only way you can add them is via add-ons. What version of Firefox did you update from?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(xircal)
Resolution: --- → INVALID
(Reporter)

Comment 3

2 years ago
(In reply to :Gijs Kruitbosch from comment #2)
> You can't add flexible spaces at all in Firefox. The only way you can add
> them is via add-ons. What version of Firefox did you update from?

Here's a link to a youtube video which shows me adding a flexible space to FF47.0 : https://youtu.be/u4BHGUtlpMk
I have Classic Theme Restorer installed since I don't like tabs on top, but I can't see any option concerning flexible spaces. 

I upgraded from 46.0.1 (FF is configured to upgrade automatically and has been installed on my laptop since February 2014).

Comment 4

2 years ago
(In reply to xircal from comment #3)
> (In reply to :Gijs Kruitbosch from comment #2)
> > You can't add flexible spaces at all in Firefox. The only way you can add
> > them is via add-ons. What version of Firefox did you update from?
> 
> Here's a link to a youtube video which shows me adding a flexible space to
> FF47.0 : https://youtu.be/u4BHGUtlpMk
> I have Classic Theme Restorer installed since I don't like tabs on top, but
> I can't see any option concerning flexible spaces. 

CTR is what produces the option to create flexible spaces. You should talk to its author about the problem you're having.
Flags: needinfo?(xircal)

Comment 5

2 years ago
I have no issues to move/remove flexible spaces added by CTR add-on in Fx 29-50. If the issue is really caused by CTR (and not a broken profile), resetting toolbar configuration will help.

It is always possible to use "Restore Defaults" button in browsers customizing mode to reset all toolbar configuration (incl. flexible spaces).
You need to log in before you can comment on or make changes to this bug.