Closed Bug 1281528 Opened 4 years ago Closed 4 years ago

Switching between multiple monitors with different DPI scaling does not always resize tab content

Categories

(Core :: Widget: Cocoa, defect)

47 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1154125

People

(Reporter: premaljhaveri, Unassigned)

Details

Attachments

(1 file)

Attached file screenshots.zip
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36

Steps to reproduce:

I have two external monitors DELL P2714H & DELL P2414H (1920 x 1080) usually connected to my mac - MacBook Pro (Retina, 15-inch, Mid 2015). 

I seem to get this issue when i come back from meetings ( essentially disconnect & connect external monitors). 

I only have adblock installed and am able to reproduce this with and without adblock enabled. 

I am also able to reproduce this when i connect the external monitors ( the tab content view size is very small on the external monitor) and when i disconnect the monitors ( the tab view is offcentered and looks very wrong - attached screenshot ) 

Funny thing is that once in this state if i open a new tab it is of the wrong size. ( attached screenshots also )

Behavior is similar to what is viewed on windows 
https://bugzilla.mozilla.org/show_bug.cgi?id=1279470
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Can provide more info as required. Need to add the behavior happens very frequently but not always.
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Could you try the latest Nightly version from https://nightly.mozilla.org/ and see if the problem still occurs? I'm wondering if this is the same issue as bug 1154125, where a patch recently landed to improve the reliability of resolution switching.
Flags: needinfo?(premaljhaveri)
First look, it does seem that issue is fixed. I will test it for couple of days more !

Awesome thanks.. now changing the default browser to Nightly :)!
Great, thanks for checking. I'm going to close this as a duplicate of bug 1154125, then.

If you do encounter further problems, please file a new report with details.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(premaljhaveri)
Resolution: --- → DUPLICATE
Duplicate of bug: 1154125
You need to log in before you can comment on or make changes to this bug.