Closed Bug 1281598 Opened 6 years ago Closed 2 years ago

Remove mozilla::DeclVal since std::declval is now safe to use

Categories

(Core :: MFBT, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1625138

People

(Reporter: seth, Unassigned)

Details

It looks like we're relying on std::declval in existing code, e.g. in Skia:

https://dxr.mozilla.org/mozilla-central/source/gfx/skia/skia/src/animator/SkMemberInfo.h#115

I suspect this means that we're at the point where mozilla::DeclVal is redundant. Let's remove it and switch existing users over to std::declval.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1625138
You need to log in before you can comment on or make changes to this bug.