Closed Bug 1281619 Opened 4 years ago Closed 4 years ago

Land version 1.4.1 of the Loop system add-on in mozilla-central

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox48 fixed, firefox49 fixed, firefox50 fixed)

RESOLVED FIXED
mozilla50
Tracking Status
firefox48 --- fixed
firefox49 --- fixed
firefox50 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

()

Details

(Whiteboard: [btpp-fix-now])

Attachments

(2 files)

Attachment #8764390 - Flags: review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/f3ec3e747ff9
Land version 1.4.1 of the Loop system add-on in mozilla-central, rs=Standard8 for already reviewed code.
Summary of release:

- Improved metrics around connections (bug 1281252) for better diagnosis.
- Removed unused telemetry histograms (bug 1275088)
- Removed various obsolete code
- Updated mocha and react libraries
https://hg.mozilla.org/mozilla-central/rev/f3ec3e747ff9
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Comment on attachment 8764390 [details] [diff] [review]
Land version 1.4.1 of the Loop system add-on in mozilla-central, rs=Standard8 for already reviewed code.

Approval Request Comment
[Feature/regressing bug #]: Firefox Hello - metrics improvements
[User impact if declined]: This release is mainly to give us an additional data point so that we can tell if WebRTC conversations that don't complete successfully actually managed to complete connection - this will help with diagnosis for the actual cause of current issues.
[Describe test coverage new/current, TreeHerder]: Has unit & integration tests, landed in m-c.
[Risks and why]: Low, mainly code removals, a couple of fixes, and an additional bit of logging for improveming metrics.
[String/UUID change made/needed]: None
Attachment #8764390 - Flags: approval-mozilla-beta?
Attachment #8764390 - Flags: approval-mozilla-aurora?
Comment on attachment 8764390 [details] [diff] [review]
Land version 1.4.1 of the Loop system add-on in mozilla-central, rs=Standard8 for already reviewed code.

Update Hello, taking it.
Should be in 48 beta 4
Attachment #8764390 - Flags: approval-mozilla-beta?
Attachment #8764390 - Flags: approval-mozilla-beta+
Attachment #8764390 - Flags: approval-mozilla-aurora?
Attachment #8764390 - Flags: approval-mozilla-aurora+
has problems uplifting to beta:

grafting 351464:0e888cae95ca "Bug 1281619 - Land version 1.4.1 of the Loop system add-on in mozilla-central, rs=Standard8 for already reviewed code. a=sylvestre"
merging browser/extensions/loop/chrome/content/panels/css/desktop.css
merging browser/extensions/loop/chrome/content/shared/css/common.css
merging browser/extensions/loop/chrome/content/shared/js/activeRoomStore.js
merging browser/extensions/loop/chrome/content/shared/test/activeRoomStore_test.js
merging browser/extensions/loop/chrome/test/mochitest/browser.ini
merging browser/extensions/loop/test/functional/manifest.ini
warning: conflicts while merging browser/extensions/loop/chrome/content/panels/css/desktop.css! (edit, then use 'hg resolve --mark')
warning: conflicts while merging browser/extensions/loop/test/functional/manifest.ini! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(standard8)
Fixed, a few bits of simple bitrot caused by tree-wide changes:

https://hg.mozilla.org/releases/mozilla-beta/rev/b98e6837de52c839aa3f2a222c70c53038c63527
Flags: needinfo?(standard8)
Blocks: 1282823
Approval Request Comment
[Feature/regressing bug #]: Firefox Hello.

This is part of the Firefox Hello 1.4.2 system add-on update that shipped to 47.0.1 users (along with bug 1273671 and bug 1282899).

It should be landed in release should there be another dot release, so that users get the correct version of the add-on.
Attachment #8771389 - Flags: approval-mozilla-release?
Attachment #8771389 - Attachment is patch: true
Comment on attachment 8771389 [details] [diff] [review]
mozilla-release version

Don't think we will do a dot release of 47
Attachment #8771389 - Flags: approval-mozilla-release? → approval-mozilla-release-
You need to log in before you can comment on or make changes to this bug.