Top sites is not displayed when tapping the URL Bar on a new tab with homepage

VERIFIED FIXED

Status

()

Firefox for iOS
General
--
major
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: TeoVermesan, Assigned: bkmunar)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios-v5.0 verified, fxios-v5.1 fixed, fxios-v6.0 fixed, fxios5.1+)

Details

Attachments

(1 attachment)

PR
48 bytes, text/x-github-pull-request
jhugman
: review+
Details | Review | Splinter Review
(Reporter)

Description

2 years ago
version 5.0 (1)
Steps to reproduce:
1. Go to settings and set a homepage
2. Set New Tab to "Show your Homepage"
3. Open a new tab
4. Tap the URL Bar

Expected results:
- about:home is displayed

Actual results:
- The page is displayed in edit mode
(In reply to Teodora Vermesan (:TeoVermesan) from comment #0)
> version 5.0 (1)
> Steps to reproduce:
> 1. Go to settings and set a homepage

I set my homepage to http://reddit.com

> 2. Set New Tab to "Show your Homepage"
> 3. Open a new tab

I get http://reddit.com

> 4. Tap the URL Bar

The URL is editable

> Expected results:
> - about:home is displayed
> 
> Actual results:
> - The page is displayed in edit mode

What am I missing? I can't reproduce. Why would about:home be displayed if I set a custom homepage to a site.
Flags: needinfo?(teodora.vermesan)
Actually never-mind, I misunderstood. We should be showing the panels, otherwise the only access to them is via the me menu button shortcuts.
tracking-fxios: --- → ?

Updated

2 years ago
Severity: normal → major
status-fxios-v5.0: --- → affected
status-fxios-v6.0: --- → affected

Updated

2 years ago
Flags: needinfo?(teodora.vermesan)
(Assignee)

Updated

2 years ago
Assignee: nobody → bmunar
(Assignee)

Comment 3

2 years ago
so speaking with tecgirl about this, I'm assuming that you implemented to not show about:home on url taps for blank pages and homepages? If so and if that's part of the plan, I'll leave it to tecgirl to come in with the final say to see if that needs to be changed. If it needs to be changed, I think it's a simple 1-3 liner right?
Flags: needinfo?(randersen)
Flags: needinfo?(jhugman)
The new tab behaviour is fairly under-specced. 

My reasoning for new tab as: 

blank: tapping on the URL bar was the only action that makes sense after opening the new tab. If this is automatic, and the homepanels are displayed, this is indistinguishable from the previous behaviour.

homepage: the homepage is more like a web page than a home panel, and the URL should be editable. Much less clear reasoning for why this shouldn't bring up the Home panel when tapping on the URL bar.

> If it needs to be changed, I think it's a simple 1-3 liner right?
Correct.

Relevant line is: https://github.com/mozilla/firefox-ios/blob/0af1065d0f1016ade7e45b40b3d27cd27c27b6cb/Client/Frontend/Browser/BrowserViewController.swift#L1537
Flags: needinfo?(jhugman)
This does feel kinda funky. What's the use case for "Show a Blank Page"? Can we just remove that option altogether?
(Assignee)

Comment 6

2 years ago
will wait for tecgirl to respond - i think she's flying rn.
about:home should only be displayed when tapping the Home icon. no changes should be made to the current behavior when you tap on the URLbar.
Flags: needinfo?(randersen)
(Assignee)

Comment 8

2 years ago
Created attachment 8766857 [details] [review]
PR
Attachment #8766857 - Flags: review?(jhugman)
:bkmunar: 

< if [.HomePage, .BlankPage].contains(NewTabAccessors.getNewTabPage(profile.prefs))
> if .BlankPage == NewTabAccessors.getNewTabPage(profile.prefs)

Current PR means that 'Show a Blank Page' does exactly the same as 'Show Top Sites', but for a tap. (i.e. a worse experience than Show Top Sites).

Blank page is a requirement from :dxue btw.
Flags: needinfo?(randersen)
Flags: needinfo?(bmunar)
(Assignee)

Comment 10

2 years ago
I think that's the behavior :tecgirl wants, but waiting for her confirmation/review
Flags: needinfo?(bmunar)
(Assignee)

Updated

2 years ago
Summary: about:home is not displayed when tapping the URL Bar on a new tab with homepage → Top sites is not displayed when tapping the URL Bar on a new tab with homepage
tracking-fxios: ? → 5.0+
Whiteboard: [needsuplift]
v5.x c348e81
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-fxios-v5.0: affected → fixed
status-fxios-v6.0: affected → fixed
Resolution: --- → FIXED
Whiteboard: [needsuplift]
Verifying as fixed on build 5.0(2)

about:home is displayed when following the steps from comment #0
Status: RESOLVED → VERIFIED
status-fxios-v5.0: fixed → verified
tracking-fxios: 5.0+ → 5.1+
Whiteboard: [needsuplift]
Looks like this was been resolved and already uplifted. Removing needs uplift.
status-fxios-v5.1: --- → fixed
Whiteboard: [needsuplift]
Flags: needinfo?(randersen)
You need to log in before you can comment on or make changes to this bug.