Closed Bug 1281782 Opened 4 years ago Closed 4 years ago

Unable to authenticate to Google Talk

Categories

(Chat Core :: XMPP, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
Instantbird 50

People

(Reporter: clokep, Assigned: abdelrahman)

References

Details

Attachments

(2 files)

Attached file Full debug log
Using the latest nightly (version 1.6a1pre (20160623103314)) I'm unable to log into Google Talk with the following error:

[6/23/16, 8:59:47 AM] 	ERROR (@ prpl-gtalk: XMPPSession.prototype.stanzaListeners.authDialog resource:///modules/xmpp-session.jsm:453)
TypeError: aAuthMec is undefined 

I suspect a regression from bug 1267649.
It looks like the GTalk specific auth mech was never converted to a generator:
https://dxr.mozilla.org/comm-central/source/chat/protocols/gtalk/gtalk.js#22
Blocks: 1267649
Flags: needinfo?(ab)
(In reply to Patrick Cloke [:clokep] from comment #1)
> It looks like the GTalk specific auth mech was never converted to a
> generator:
> https://dxr.mozilla.org/comm-central/source/chat/protocols/gtalk/gtalk.js#22

Yes, you are right.
Assignee: nobody → ab
Status: NEW → ASSIGNED
Flags: needinfo?(ab)
Attachment #8764617 - Flags: review?(clokep)
Comment on attachment 8764617 [details] [diff] [review]
v1 - Convert gtalk auth mechanisms to generators

Review of attachment 8764617 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! Does this need to get uplifted?
Attachment #8764617 - Flags: review?(clokep) → review+
(In reply to Patrick Cloke [:clokep] from comment #3)
> Thanks! Does this need to get uplifted?

I think no, aleth can confirm that.
Flags: needinfo?(aleth)
Bug 1267649 landed this cycle, so no.
Flags: needinfo?(aleth)
Thanks! https://hg.mozilla.org/comm-central/rev/feaa4f244243
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 50
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.