Firefox 47 will not run at all if Trusteer Rapport is installed and running

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Other
RESOLVED WORKSFORME
a year ago
3 days ago

People

(Reporter: Dave Hawley, Unassigned)

Tracking

(Blocks: 1 bug, {qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [platform-rel-IBM][platform-rel-Trusteer])

(Reporter)

Description

a year ago
User Agent: Opera/9.80 (Windows NT 5.1; Edition United Kingdom Local) Presto/2.12.388 Version/12.18

Steps to reproduce:

Updated from Firefox 46 to Firefox 47


Actual results:

The update apparently completed successfully, but Firefox 47 would not then run. Firefox.exe just appears briefly in the Windows Task Manager, and then disappears again. By process of elimination I found that Trusteer Rapport is the cause. If it's disabled Firefox 47 runs fine. There is no apparent crash in Firefox 47, it just doesn't launch. After rolling back to Firefox 46 everything is fine again.


Expected results:

Firefox 47 should have loaded and run!
User Agent  Mozilla/5.0 (Windows NT 5.1; rv:47.0) Gecko/20100101 Firefox/47.0

Hi Dave, 
I wasn't able to reproduce your issue. I have installed Trusteer Rapport and then Firefox 46.0.1. After I've installed Firefox I updated it to 47, after the update was finished, Firefox restarted and was up and running without any issues. 

Have you, by any chance, made some additional settings in Trusteer Rapport? 

Could you please reinstall Firefox directly from https://www.mozilla.org/en-US/firefox/new/?
Flags: needinfo?(dave-h)
(Reporter)

Comment 2

a year ago
Thanks Ciprian!
That is very strange as it still won't work for me.
Which version of Rapport do you have?
I'm using version 1609.65.
You are on Windows XP SP3 I take it, you appear to be from your User Agent?
Rapport is on its default settings, I have made no changes to its setup.
Interestingly, the link you provided is serving me Firefox 43.0.1, not 47!
Any idea why that would be, even on XP it should still be offering the latest version I would have thought?
Cheers, Dave.
(Reporter)

Comment 3

a year ago
Thanks Ciprian!
That is very strange as it still won't work for me.
Which version of Rapport do you have?
I'm using version 1609.65.
You are on Windows XP SP3 I take it, you appear to be from your User Agent?
Rapport is on its default settings, I have made no changes to its setup.
Interestingly, the link you provided is serving me Firefox 43.0.1, not 47!
Any idea why that would be, even on XP it should still be offering the latest version I would have thought?
Cheers, Dave.
OS: Unspecified → Windows XP
Hardware: Unspecified → x86
(Reporter)

Comment 4

a year ago
Thanks Ciprian!
That is very strange as it still won't work for me.
Which version of Rapport do you have?
I'm using version 1609.65.
You are on Windows XP SP3 I take it, you appear to be from your User Agent?
Rapport is on its default settings, I have made no changes to its setup.
Interestingly, the link you provided is serving me Firefox 43.0.1, not 47!
Any idea why that would be, even on XP it should still be offering the latest version I would have thought?
Cheers, Dave.
Flags: needinfo?(dave-h)
Thank you for your quick response. 

The reason why the link is downloading Firefox 43.0.1 can be found here https://support.mozilla.org/en-US/kb/get-latest-version-firefox-windows-xp-vista.

And yes, I used Windows XP SP3 and installed the latest version of Trusteer Raport: Emerald Build 1609.65. So the only thing I could suggest before taking this further is to reinstall Firefox from that link, and update it to the latest version. If you still encounter this issue after doing this, please post your results.
Flags: needinfo?(dave-h)
(Reporter)

Comment 6

a year ago
Thanks again Ciprian, and sorry for the multiple posts earlier on, I didn't realise that the system would send another copy of my post every time I made a change to the fields at the top!

Thanks for reminding me about the XP version problem, I did know about it but had forgotten!
I would have thought that the system would detect that I had SP3 installed on XP, and serve me the latest version, but presumably not!

Anyway, I downloaded and installed 43 into a new folder to avoid disturbing my 46 installation.
That went fine and it ran fine.
I then did the update to 47 from within 43, and the update again went fine, but when 47 tried to start the same thing happened.
There was a flash across the screen, but nothing else then happened.
Trying to run 47 subsequently produced the same as before, firefox.exe appears in the Windows Task Manager list for a second and then vanishes.
If I close down Rapport, 47 then runs normally.

Restarting Rapport with 47 running does not seem to subsequently affect the operation of 47.
I wondered if the problem was something to with the Rapport icon that appears beside the address bar.
To check this, I switched it off in Rapport, but unfortunately Firefox still won't run with Rapport running, even with the icon disabled, so it must be the loading of Rapport's monitoring into the browser, which I assume still happens even if the icon is disabled, that is causing the problem.

Cheers, Dave.
Component: Untriaged → Extension Compatibility
Flags: needinfo?(dave-h)
(Reporter)

Comment 7

a year ago
I just wanted to add, which I should have mentioned before, that running Firefox 47 in "safe mode" makes no difference to the problem.
Cheers, Dave.
(Reporter)

Comment 8

a year ago
Also to add, Firefox 47.0.1 is the same.
:(
(Reporter)

Comment 9

a year ago
Just to update this, Firefox 48.0 still shows the same problem. :-(
Is there any way to disable the Rapport extension in Firefox while Firefox isn't actually running, perhaps by editing a configuration file? I suspect the problem is being caused by the Rapport address bar icon, but as I can only run Firefox 48 with Rapport switched off, the icon is not then there of course, nor is Rapport listed in the list of add-ons. I need to be able to disable Rapport, just for Firefox only, from within Firefox. Is there any way I can do this without Firefox running?
Thanks, Dave.
(Reporter)

Comment 10

a year ago
Well, after more testing I now know that the problem is definitely related to Data Execution Prevention!
If I add Firefox.exe to the excluded applications in the DEP settings on the Windows XP System Properties, Firefox 48 then runs fine.
Unfortunately, a couple of old 16 bit programs that I still use then won't run!
It is however definitely an interaction problem with Trusteer Rapport, and by a long process of trial and error, I've now found that it works OK if I disable the "Early Browser Protection" option in Rapport's settings. This allows Firefox to run without any DEP errors.
Why this should have suddenly started with Firefox 47 is a mystery, but at least that's a workaround for the moment.
I hope the Firefox developers can find out why this is happening so everything works again as it should with its default settings.
Cheers, Dave. :-)
Blocks: 1320970
platform-rel: --- → ?
Whiteboard: [platform-rel-IBM][platform-rel-Trusteer]
Ciprian can you confirm this bug with information in comment 10?
platform-rel: ? → +
Keywords: qawanted
Flags: needinfo?(ciprian.muresan)
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID 	20170125094131
Trusteer Version: Emerald Build 1804

I am still unable to reproduce the issue. For me, Firefox starts up as expected if I have Trusteer Rapport installed. 

Dave, could you please revert all your changes to DEP, update to the latest Firefox release and see if the issue is still reproducible. Also, did you log an issue with Trusteer to see if they have anything to say about this?
platform-rel: + → ---
Component: Extension Compatibility → Other
Flags: needinfo?(ciprian.muresan) → needinfo?(dave-h)
Product: Firefox → External Software Affecting Firefox
Version: 47 Branch → unspecified
(Reporter)

Comment 13

8 months ago
Thanks Ciprian!
Actually I had almost forgotten about this.
In fact the problem went away quite a while ago, although I do still have a problem with Rapport and Firefox 51.
I worked around the original problem by switching of "early browser protection" in Rapport's settings, which allowed Firefox 47 to run.
On later version of Firefox the problem did seem to have gone away anyway, so it may only have affected 47, I now can't remember.
I think this "bug" can now be closed, as no-one else seems to have had it except me anyway.
The problem that I have now is that there is no Rapport icon in the address bar of Firefox 51, although it works fine with Firefox 50 if I revert back to that. I am using the latest version of Rapport, 3.5.1804.81, which claims to work with Firefox 51.
Of course the big fly in the ointment is that I'm still using windows XP, which means that Trusteer won't help me any more.
I have been trying to find out exactly how Rapport integrates with Firefox, it certainly isn't a normal add-on.
If you can shed any light on that I would be very interested and grateful to know, as it might give me some clue as to why it is no longer working. I can't imagine why the operating system would be a factor. Rapport still works fine with Internet Explorer 8, which is far older than Firefox 51! As long as Firefox 51 supports XP, which it does (I believe that 52 should support it too, but not after that) I don't see why it wouldn't work, unless Trusteer have deliberately blocked it from working on XP, which makes no sense if Rapport as a whole still installs and works on XP, even though unsupported.
Cheers, Dave.
Dave said Firefox is now working.
Sorry for the delay here, Rapport did actually deliberately block it from working on XP, as far as I recall.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 days ago
Flags: needinfo?(dave-h)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.