Linux: SIlverlight and Hangout plugin video and sound slows down periodically

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
2 years ago
a year ago

People

(Reporter: Nikolay Martynov, Unassigned)

Tracking

50 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160623072113

Steps to reproduce:

Watch netflix (with pipelight) or have a conversation on google hangout


Actual results:

Video and sound become jerky from time to time. When this happens plugin loader consumes ~130% cpu in top. This happens once every several minutes and lasts for several seconds, then recovers.

Problem started to appear about a month ago and is present in daily-trunk ppa builds (50a) and beta ppa builds (48a).


Expected results:

Video/sound should go smoothly.
Hi Nikolay,

I tried to reproduce this issue on Ubuntu 14.04 and 15.10, but after installing Pipelight I still can't access content from Netflix as it tells me I need Silverlight.
As for the Google Hangouts part, I held a call between 2 computers through Hangouts but CPU usage was normal(3-6%) on both PCs.
Given the fact that Pipelight is working for you, could you please try to find a regression range using the Mozregression tool?
Information on the tool is available at http://mozilla.github.io/mozregression/. Please don't hesitate to needinfo me if you encounter any problems.
Flags: needinfo?(mar.kolya)
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

2 years ago
Thanks for your response!

Just several of clarifications:

* I'm using ubuntu 16.04
* You may need to change UA string for netflix to access it: 'Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20131011 Firefox/38.0'
* It looks like issue exists on Haswell CPU, but I couldn't reproduce it on Skylake.

I'll see if I can find out more with mozregression.
(Reporter)

Comment 3

a year ago
I've tried mozregression and it still happens on the builds that are way past the time it used to work fine. So maybe something else got updated that caused that. Sorry for buzz.
Based on comment 3 I'm pretty sure this is not related to Firefox so I'll go ahead and Resolve this as Incomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mar.kolya)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.