Closed Bug 1282013 Opened 5 years ago Closed 4 years ago

Geolocation fires failure, Position acquisition timed out after already returning success

Categories

(Core :: DOM: Geolocation, defect)

47 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1283563

People

(Reporter: zac.spitzer, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

Steps to reproduce:

On Windows 10 x64, firefox fires the geolocation failure callback after it has already returned a successful position. Note this desktop has no WiFI




Actual results:

the problem is intermittent, usually after a couple of goes, it will return
PositionError { code: 3, message: "Position acquisition timed out" }
after already returning a successful position

https://jsbin.com/nupuyo/edit?html,console,output






Expected results:

Failure callback should not be triggered if there was a successful result
Component: Untriaged → Geolocation
Product: Firefox → Core
Michelangelo, can you take a look and comment? Thanks.
Flags: needinfo?(michelangelo)
(In reply to Zac Spitzer from comment #0)

> Failure callback should not be triggered if there was a successful result

The issue seems confirmed on 47; it works as expected in Nightly (50).
Zac, would it be possible for you to try this on the Nightly as well?

Thanks!
Flags: needinfo?(michelangelo)
ni for comment 2
Flags: needinfo?(zac.spitzer)
Haven't heard from Reporter for a while. Per comment 2, I am going to close it as WORKSFORME. Feel free to reopen if the issue exists.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(zac.spitzer)
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1283563
You need to log in before you can comment on or make changes to this bug.