about: page displays bigger than screen both in height and width after session restore

RESOLVED DUPLICATE of bug 1279443

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1279443
3 years ago
3 years ago

People

(Reporter: wgianopoulos, Unassigned)

Tracking

({regression})

49 Branch
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 fix-optional, firefox50 fixed)

Details

(Reporter)

Description

3 years ago
See summary.
(Reporter)

Updated

3 years ago
Summary: about: page displays 2X bigger than screen than screen both in height and width on NEXUS 2012 tablet → about: page displays 2X bigger than screen both in height and width on NEXUS 2012 tablet
(Reporter)

Updated

3 years ago
Summary: about: page displays 2X bigger than screen both in height and width on NEXUS 2012 tablet → about: page displays 2X bigger than screen both in height and width on NEXUS 2012 tablet under Aurora
(Reporter)

Comment 1

3 years ago
I suspect the check-in for bug 1262807.
Keywords: regression
(Reporter)

Updated

3 years ago
Blocks: 1262807
(Reporter)

Comment 2

3 years ago
It seems my nightly build was a day behind. This fails on trunk also.  I will try to reproduce in my own build and see if I can verify bug 1262807 via backout.  BTW, what ever happened to things need to bake on trunk for a week before being uplifted?
Summary: about: page displays 2X bigger than screen both in height and width on NEXUS 2012 tablet under Aurora → about: page displays 2X bigger than screen both in height and width on NEXUS 2012 tablet
Version: 49 Branch → Trunk
about:firefox renders fine for me on a Nexus 4. I strongly doubt bug 1262807 is related to this. Removing dependency unless you have verified it by backout or bisection.
No longer blocks: 1262807
Hm, I *do* see this if I kill and restart the browser while about:firefox is loaded; it looks like maybe it's getting session-restored at the wrong zoom level. Perhaps related to bug 810981.
I bisected on m-c and got [1], which includes bug 810981 - pretty sure that's the culprit. Jan, can you look into this?

[1] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3435dd7ad71fe9003bdeee18fd38d815e033beef&tochange=dc4d7f68030e9edd22ad0bb0bd2244d047dd767d
Blocks: 810981
Severity: major → normal
status-firefox48: --- → unaffected
status-firefox49: --- → affected
status-firefox50: --- → affected
Flags: needinfo?(jh+bugzilla)
Priority: -- → P3
Summary: about: page displays 2X bigger than screen both in height and width on NEXUS 2012 tablet → about: page displays bigger than screen both in height and width after session restore
Version: Trunk → 49 Branch
(Reporter)

Comment 6

3 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)
> Hm, I *do* see this if I kill and restart the browser while about:firefox is
> loaded; it looks like maybe it's getting session-restored at the wrong zoom
> level. Perhaps related to bug 810981.

You are right this only seems to happen on a restored window so probably the other bug.
Going out on a limb here...
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jh+bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1279443
Getting bug this off our list as we are tracking dupe bug 1279443.
status-firefox49: affected → fix-optional
status-firefox50: affected → fixed
You need to log in before you can comment on or make changes to this bug.