RDM touch simulation mode triggers hover states

VERIFIED FIXED in Firefox 68

Status

defect
P1
normal
VERIFIED FIXED
3 years ago
11 days ago

People

(Reporter: bigben, Assigned: mtigley)

Tracking

(Blocks 2 bugs)

Trunk
Firefox 68
Dependency tree / graph

Firefox Tracking Flags

(firefox50 wontfix, firefox68 verified, firefox69 verified)

Details

(Whiteboard: [rdm-mvp])

Attachments

(1 attachment)

Reporter

Description

3 years ago
The RDM touch simulation mode captures mouse events pretty well, and should be easy to use once Bug 1269882 has landed. However, it still triggers CSS :hover states, whereas this shouldn't be the case on a mobile device.

[Steps to reproduce]:
1. Launch Firefox.
2. Enable the devtools.responsive.html.enabled pref, and restart Firefox if necessary
3. Open http://www.w3schools.com/cssref/tryit.asp?filename=trycss_sel_hover, or any website using CSS hover states
4. Launch RDM on this website
5. Move your mouse over elements using this to see how it looks
6. Now enable touch simulation. You might have to reload the iframe by calling reload() on it in the console.
7. Move your mouse over these elements again.

[Expected result]:
- The hover state doesn't trigger anymore. There should only be a visible change when you click on the link/element ("sticky" hover).

[Actual result]:
- The hover state is still triggered. We shouldn't be able to interact with the page this way.
Whiteboard: [multiviewport][triage]
Priority: -- → P3
Whiteboard: [multiviewport][triage] → [multiviewport] [reserve-rdm]
Flags: qe-verify?

Updated

Last year
Product: Firefox → DevTools
Assignee

Updated

5 months ago
Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Assignee

Updated

5 months ago
Blocks: 1282089
Duplicate of this bug: 1535560
See Also: → 1538709
See Also: 1538709
Assignee: mtigley → nobody
Status: ASSIGNED → NEW
Flags: qe-verify?
Priority: P3 → P2
Whiteboard: [multiviewport] [reserve-rdm] → [rdm-mvp]
Assignee

Comment 3

3 months ago

After briefly looking into this issue with Patrick, it looks like we can remove element hover states by calling the InspectorUtils' removeContentStateon the target element. The AccessibleWalkerActor does something similar here: https://searchfox.org/mozilla-central/rev/ddd1679c0534f7ddf36cafddd17b710c4fefe3c4/devtools/server/actors/accessibility/walker.js#605-626 .

So I imagine we can do the same thing in TouchSimulator's handleEvent.

Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Priority: P2 → P1

Comment 6

3 months ago
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/106e58c798ef
Don't allow RDM to show triggered hover states while touch is enabled. r=pbro

Comment 7

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment 8

22 days ago

This issue is verified as fixed in Nightly 69.0a1 (2019-06-03).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.