Consolidate Build Config components

RESOLVED DUPLICATE of bug 1406536

Status

()

RESOLVED DUPLICATE of bug 1406536
2 years ago
11 months ago

People

(Reporter: gps, Assigned: dylan)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
There are multiple "Build Config" components throughout Bugzilla. Core :: Build Config is the main one. For historical reasons, there exist some one-off "Build Config" components related to Firefox/Gecko development that add little to no value.

I am requesting the following components be consolidated into Core :: Build Config:

Firefox :: Build Config
Firefox for Metro :: Build Config
Toolkit :: Build Config

Please move all bugs in the aforementioned components into "Core :: Build Config" and delete the then defunct components from Bugzilla.

Please do not act on this bug until at least 2016-06-29 (so there is time for people to raise objections).
(In reply to Gregory Szorc [:gps] from comment #0)
> There are multiple "Build Config" components throughout Bugzilla. Core ::
> Build Config is the main one. For historical reasons, there exist some
> one-off "Build Config" components related to Firefox/Gecko development that
> add little to no value.
> 
> I am requesting the following components be consolidated into Core :: Build
> Config:
> 
> Firefox :: Build Config
> Firefox for Metro :: Build Config
> Toolkit :: Build Config

Might as well fold Firefox for Android :: Build Config and IDE Support into Core :: Build Config as well.

For the record, I've nothing against this plan.
Just clear the needinfo when ready to move on this to keep it off our radar in the meantime.
Flags: needinfo?(gps)
(Reporter)

Comment 3

2 years ago
Fire at will.
Flags: needinfo?(gps)

Updated

2 years ago
Assignee: nobody → dkl
Status: NEW → ASSIGNED
(Assignee)

Updated

a year ago
Assignee: dkl → dylan
(Assignee)

Updated

11 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1406536
You need to log in before you can comment on or make changes to this bug.