Closed Bug 1282280 Opened 4 years ago Closed 4 years ago

Give viewPickerPopup and folderLocationPopup a menu look

Categories

(Thunderbird :: Theme, defect)

All
Windows
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 50.0

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(2 files, 1 obsolete file)

From bug 1280429 comment 5:
Yes, but it is a mess in the filter editor, that the first menupopup of the picker is white and flat but the subsequent menupoups coming from menus are gray and 3d relief (and possibly with the vertical lines). I vaguely remember we wanted to fix this somewhere but can't remember if it was successful. That should be discussed in a new bug as it is not straightforward (there are multiple options to do).
Attached patch pickerColors.patch (obsolete) — Splinter Review
This gives the menupopup[type="folder"], the popup which are showing the message folders, the menu appearance. And I also added rules for the #viewPickerPopup, the popup from Mail Views menulist, to look similar.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8765220 - Flags: review?(mozilla)
Can you please point out all the places I need to look at and/or attach a/some screenshot(s).

I've looked around the menulist to select folders in the filter definition; I noticed the vertical line, but I think there is padding missing to the right of it.
The only menulist (which I know) I've not checked, and it has menuitems in it. All other have only menu.

Menulists I know:
FolderPicker in main toolbar (needs to add through customize)
Filters for: in Message Filters
Run selected Filter(s) on: in MessageFolter
Choose Folder in Filter Editor
The folder menulists in Copies & Folders of Account Manager (grey menupopup on grey dialog background isn't optimal, but this ones aren't used often)

Maybe some more but I'm not aware of them.
Attachment #8765220 - Attachment is obsolete: true
Attachment #8765220 - Flags: review?(mozilla)
Attachment #8765233 - Flags: review?(mozilla)
Comment on attachment 8765233 [details] [diff] [review]
pickerColors.patch v2

Review of attachment 8765233 [details] [diff] [review]:
-----------------------------------------------------------------

I've checked the folder menulist mentioned in comment #3 on Windows 7 and they look good now (and better than without the patch). I'm not really an expert on the CSS stuff and I assume that I may not have covered all the cases. Given that our other reviewers are on Linux or Mac, I guess we'll have to live with my humble review ;-(
Attachment #8765233 - Flags: review?(mozilla) → review+
http://hg.mozilla.org/comm-central/rev/eabc64bac050
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 50.0
(In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #4)
> I've checked the folder menulist mentioned in comment #3 on Windows 7 and
> they look good now ...
I've just checked it on Windows 10 and I can't see a vertical line. Is that intentional or am I missing something? Would you like a screenshot?
Windows 10 has no vertical lines in menus.
Maybe the problem is also on Linux :)

So which version was chosen here? Are now all levels of the folder picker coming from a menulist a 3d-relief menu, or are they all white flat?
(In reply to Richard Marti (:Paenglab) from comment #7)
> Windows 10 has no vertical lines in menus.
Yes, indeed.
(In reply to :aceman from comment #8)
> Maybe the problem is also on Linux :)

I've checked this on Linux and it looked good for me. But I can recheck this afternoon.
Checked again on Linux. The menulist menupopups and menuitems have the  menupop or menuitem -moz-appearance and are looking correct.
Yes, looks fine to me on Linux before & after the patch (=> needs no fix).
You need to log in before you can comment on or make changes to this bug.