Closed Bug 1282331 Opened 3 years ago Closed 3 years ago

Get Active Frame does not return web element

Categories

(Testing :: Marionette, defect)

Version 3
defect
Not set

Tracking

(firefox50 fixed)

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed

People

(Reporter: njasm, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

Navigate to: "http://www.w3schools.com/ajax/tryit.asp?filename=tryajax_get"
SwitchToFrame : "iframeResult" 
call GetActiveFrame after the switch.



Actual results:

the response structure is: [1,57,null,{"value":"9609e48d-e40e-504f-9ca8-ced862ba17c6"}]



Expected results:

Marionette on success should return a "WebElement" response structure like :
[1,52,null,{"value":{"element-6066-11e4-a52e-4f735466cecf":"9609e48d-e40e-504f-9ca8-ced862ba17c6","ELEMENT":"9609e48d-e40e-504f-9ca8-ced862ba17c6"}}]
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Summary: Marionette return value of GetActiveFrame() shouldn't return a WebElement? → Marionette return value of GetActiveFrame() - Shouldn't return a WebElement on success?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86_64 → All
Summary: Marionette return value of GetActiveFrame() - Shouldn't return a WebElement on success? → Get Active Frame does not return web element
Get Active Frame does not appear to be defined in the WebDriver specification, but it is implemented in Marionette.
True, there's nothing in the WebDriver Spec about Get Active Frame. 

But should the method return or not a WebElement structure for further querying by clients if wanted? if so, do you think it should be an easy fix?
Get Active Frame is a Mozilla only API and is currently used this way. I am happy for you to try update the code accordingly and review the patch
Attachment #8769486 - Flags: review?(dburns)
Attachment #8769486 - Flags: feedback?(dburns)
I've run the tests after for marionette, with ./mach marionette-test

And I've add one test in the red. apparently unrelated to the code I've changed.

ERROR test_key_actions.py TestKeyActions.test_open_in_new_window_shortcut

I've look into it, and it's throwing a TimeOutException on wait_condition function. Since I cloned the repository and assumed that the code in mozilla-central is always passing. I not sure, if I didn't introduce a regression, or timeout test are "intermittent by nature".

My question is, since I know the commit hash that I've started changing code, is there any webplatform/try server that I can look into it, and see if the tests there was passing before my changes?
s/I've add one test in/I've had one test in
s/I not sure/I'm not sure
s/timeout test are/timeout tests are
s/tests there was passing/tests there were passing


PS - Sorry for my bad English, English is not my native language, and It's Sunday/Euro 2016 Final day :)
Attachment #8771144 - Flags: review?(dburns)
Attachment #8769486 - Flags: review?(dburns)
Attachment #8769486 - Flags: feedback?(dburns)
Comment on attachment 8769486 [details] [diff] [review]
bug_#1282331_GetActiveFrame1.patch

the patch https://bugzilla.mozilla.org/attachment.cgi?id=8771144
makes this attachment patch in bugzilla obsolete. in fact they're the same.
Attachment #8769486 - Attachment is obsolete: true
looks good, have pushed to try and then will check the results before finishing the review
Comment on attachment 8771144 [details]
Bug 1282331 - Refactor GetActiveFrame to return WebElement

https://reviewboard.mozilla.org/r/64392/#review61876
Attachment #8771144 - Flags: review?(dburns) → review+
Pushed by dburns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/57fe98edfc3d
Refactor GetActiveFrame to return WebElement r=automatedtester
https://hg.mozilla.org/mozilla-central/rev/57fe98edfc3d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.