Closed Bug 1282367 Opened 5 years ago Closed 5 years ago

Location bar detects anything with a dot as a URL

Categories

(Firefox :: Address Bar, defect)

47 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1256074

People

(Reporter: miha.frangez, Unassigned)

Details

Attachments

(1 file)

Attached image Screenshot of the bug
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

Type anything containing a dot and no spaces into the location bar


Actual results:

It detected a filename as a URL (see attatchment)


Expected results:

It should still give the user the option to search (see attatchment).

It would be even better if it checked the list of official TLDs and if it didn't match any, reverse the order of the suggestions in the bottom screenshot (for URLs like "something.lan").
Component: Untriaged → Location Bar
I think the "Expected Results" could be:
```
It searches the filename by default.
```

It's more efficient for end-users.
Currently if we fill in an email address or an API keyword(e.g. `Object.keys`) on location bar, it will detect them as URLs and Firefox will show `Server not found`.
Hi Nick,

What do think about the bug?

I think we should fix this to enhance our user experience.
Flags: needinfo?(nchapman)
Nick is no more firectly following this project.

I think something like bug 1256074 could solve your concern, what do you think?
Flags: needinfo?(nchapman)
(In reply to Marco Bonardo [::mak] (Away 6-20 Aug) from comment #4)
> I think something like bug 1256074 could solve your concern, what do you
> think?

I agree bug 1256074 is the better approach. Given comment 0 suggests the same approach, I would recommend we dup the bug together?

(In reply to miha.frangez from comment #0)
> It would be even better if it checked the list of official TLDs and if it
> didn't match any, reverse the order of the suggestions in the bottom
> screenshot (for URLs like "something.lan").

This is a nice suggestion too. We do have public suffix list [1] built into Gecko; I don't know if front-end JS has access to it thought.

[1] https://publicsuffix.org/list/public_suffix_list.dat

Who can sign-off this kind of behavioral change if not nchapman?
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #5)
> This is a nice suggestion too. We do have public suffix list [1] built into
> Gecko; I don't know if front-end JS has access to it thought.

See bug 1080682.

> Who can sign-off this kind of behavioral change if not nchapman?

Our product manager is now Javaun Moradi.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256074
You need to log in before you can comment on or make changes to this bug.