Closed Bug 1282486 Opened 6 years ago Closed 5 years ago

Plugin fallback rule - don't use fallback when it contains "install Flash" instructions

Categories

(Core :: Plug-ins, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1282484

People

(Reporter: Felipe, Assigned: Felipe)

References

Details

Attachments

(1 file)

Add a rule to the Flash fallback mechanism (bug 1282484) to not use the fallback content when it contains any text that might indicate that they are instructions about installing Flash.

We should try to detect the words "Adobe", "Flash", and possibly "install" or "download" in several popular languages.
Blocks: 1282487
Priority: -- → P2
Brad is working on this "Install Flash" detection in bug 1289802.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1289802
This is distinctly different from bug 1289802. In that bug, the site didn't use an <object> tag at all. In this case, the site *did* use an <object> tag, and we'd normally use fallback content, but we decide not to because of this exception.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: 1282484
No longer depends on: 1282484
No longer blocks: 1277346
Assignee: nobody → felipc
Status: REOPENED → ASSIGNED
Attachment #8808768 - Flags: review?(kyle)
Attachment #8808768 - Flags: review?(kyle)
Merged to bug 1282484
Status: ASSIGNED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1282484
You need to log in before you can comment on or make changes to this bug.