CTRL+LETTER crashes mozilla in Print Preview mode

VERIFIED DUPLICATE of bug 128449

Status

()

Core
Print Preview
--
critical
VERIFIED DUPLICATE of bug 128449
17 years ago
16 years ago

People

(Reporter: Pierre Chanial, Assigned: rods (gone))

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Linux build 2002 02 25 08.

Steps to reproduce:
1) go to http://www.mozilla.org/start
2) print preview
3) click on the layout (required step due to bug 126808)
4) type CTRL-A or CTRL-N or CTRL T or CTRL-R, CTRL-U or any letter ex: CTRL-$

Result: crash
Reproducibility: always
Talkbacks ID (should have the same stack):
TB3470170W
TB3470232M
TB3470284Q
TB3470333E
TB3470467W
TB3470513X
Note this bug may be linux only, because it is incompatible with the report in
bug 126719 that I can not reproduce.

Comment 1

17 years ago
 DUP of  127226 ?
(Reporter)

Comment 2

17 years ago
In bug 127226, from what I understood, there is a mention that one has to click
on the next page button in the PP toolbar to crash mozilla.
But I could not reproduce the crash.
stephend, could you have a look to the stacks and attach one, please?
CC'ing PP P-ple.
0x00000000
nsMenuPopupFrame::ShortcutNavigation()
nsMenuListener::KeyPress()
nsEventListenerManager::HandleEvent()
nsXULDocument::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleChromeEvent()
GlobalWindowImpl::HandleDOMEvent()
nsDocument::HandleDOMEvent()
nsGenericElement::HandleDOMEvent()
PresShell::HandleEventInternal()
PresShell::HandleEvent()
nsViewManager::HandleEvent()
nsView::HandleEvent()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::OnInput()
handle_key_press_event()
dispatch_superwin_event()
handle_gdk_event() 
Keywords: crash
(Assignee)

Comment 4

17 years ago
I am dup'ing this to Bug 128449 because it is a general problem of not
"preventing" certain event from geting processed. The fix in 128449 will fix
this bug.

*** This bug has been marked as a duplicate of 128449 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.