Closed Bug 1282628 Opened 5 years ago Closed 5 years ago

[TSF] Korean IME doesn't work well with autocomplete

Categories

(Core :: Widget: Win32, defect)

All
Windows
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla50

People

(Reporter: mujjingun, Unassigned)

References

Details

(Keywords: inputmethod)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160627004013

Steps to reproduce:

In the latest Firefox Developer Edition(2016-06-27), 
I can reproduce by following these steps:

1. Open Firefox.
2. Click on the address bar(or the search bar).
3. Type using Korean IME, or any composition IME, like Japanese or Chinese.
4. Keep typing after autocomplete window shows up.


Actual results:

When typing IME characters, all of the intermediate steps remain while typing, which should be eliminated after showing the completed form of the character. For example, when typing the Korean word "파폭", "ㅍ파팦파포폭" is typed instead. This only occurs after the autocomplete windows shows up.


Expected results:

Only the completed form of the character should remain on the text area.
I don't understand what occurs in your environment because Firefox stops (closes) autocomplete when IME starts composition. Do you reproduce in safe mode too?
Flags: needinfo?(mujjingun)
(In reply to Masayuki Nakano [:masayuki] (Mozilla Japan) from comment #1)
> I don't understand what occurs in your environment because Firefox stops
> (closes) autocomplete when IME starts composition. Do you reproduce in safe
> mode too?

Yes, I can reproduce it in safe mode too. For me, firefox doesn't close autocomplete when IME starts composition.
(In reply to Masayuki Nakano [:masayuki] (Mozilla Japan) from comment #1)
> I don't understand what occurs in your environment because Firefox stops
> (closes) autocomplete when IME starts composition. Do you reproduce in safe
> mode too?

The trick to force autocomplete show up is to press space, and then keep typing.

Look at this gif and try to reproduce it once again:

https://gfycat.com/LastCandidBison
Okay, I guess that this is caused by very odd behavior of Korean TIPs. That causes odd CompositionEvents. Therefore, our autocomplete module cannot handle them as expected.

However, actually I cannot reproduce this bug with Japanese TIPs too. But you said "3. Type using Korean IME, or any composition IME, like Japanese or Chinese.", did you test this with them actually?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Masayuki Nakano [:masayuki] (Mozilla Japan) from comment #4)
> Okay, I guess that this is caused by very odd behavior of Korean TIPs. That
> causes odd CompositionEvents. Therefore, our autocomplete module cannot
> handle them as expected.
> 
> However, actually I cannot reproduce this bug with Japanese TIPs too. But
> you said "3. Type using Korean IME, or any composition IME, like Japanese or
> Chinese.", did you test this with them actually?

I'm sorry, I didn't actually didn't test it. I just assumed it was a problem with all IMEs, my bad. This is my first bug report, actually. Should I create a new bug report with the correct description?
No problem, keep open this bug.
Flags: needinfo?(mujjingun)
Component: Untriaged → Widget: Win32
Keywords: inputmethod
OS: Unspecified → Windows
Product: Firefox → Core
Hardware: Unspecified → All
Summary: IME input in address bar and search bar broken → [TSF] Korean IME doesn't work well with autocomplete due to odd composition events
Version: 49 Branch → Trunk
My investigation perhaps wrong. *I* already fixed the odd composition events with Korean TIP at 46. So, that shouldn't cause this bug. Actually, I don't see any odd behavior in input event test suite.

On the other hand, for testing, I'm using patched build of bug 1224994. On the test build, I cannot reproduce this bug. I'm not sure why that can fix this bug, but I should test this again with tomorrow's Nightly build which might include the fix.
Summary: [TSF] Korean IME doesn't work well with autocomplete due to odd composition events → [TSF] Korean IME doesn't work well with autocomplete
I cannot reproduce this bug anymore with latest Nightly builds. Should be fixed by bug 1224994.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.