support surrogate character rendering under Mac.

VERIFIED FIXED in mozilla1.2alpha

Status

()

VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: ftang, Assigned: ftang)

Tracking

({intl, topembed})

Trunk
mozilla1.2alpha
PowerPC
Mac OS X
intl, topembed
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [eta: 8/20/2002], URL)

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
we should try Code 2001 font and the ms surrogate chinese font and make mac
render surrogate if they are installed.

Updated

17 years ago
Keywords: intl
QA Contact: ruixu → ylong
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

17 years ago
here is the infor for code 2001 font.
>Frank, Shanjian,
>
>James Kass' font works well and covers the characters in the example
>page at: http://www.geocities.com/i18nguy/unicode-example-plane1.html
>
>The page has some information on setting up Windows for surrogates.
>
>Kass' Code 2001 font is at:
>http://home.att.net/~jameskass/CODE2001.ZIP
>
(Assignee)

Comment 2

17 years ago
also, look at http://www.microsoft.com/downloads/release.asp?ReleaseID=31326 for
MS surrogate font
(Assignee)

Comment 3

17 years ago
the ms chinese font could be fonta at
http://www.microsoft.com/downloads/release.asp?ReleaseID=32385
(Assignee)

Updated

17 years ago
Blocks: 157673
(Assignee)

Updated

17 years ago
Keywords: nsbeta1+
Whiteboard: [eta: 8/20/2002]
Target Milestone: --- → mozilla1.2alpha

Updated

17 years ago
Hardware: PC → Macintosh
(Assignee)

Comment 4

17 years ago
I hit a general ATSUI problem before I can implement this.
that problem is solved in bug 160001
(Assignee)

Comment 5

17 years ago
Created attachment 93203 [details] [diff] [review]
patch to enable surrogte on mac
(Assignee)

Comment 6

17 years ago
to see the effect of the patch, do the folloiwng


1. install chinese surrogate font . 
  (if you are internal in Netscape. save 
http://warp.mcom.com/u/ftang/fonts/schinese/SURSONG.TTF  into 
Library:Fonts:SURSONG.TTF under your MacOS X.)

2. visit http://people.netscape.com/ftang/testscript/gb18030/gb18030.cgi?page=596
you will see all text display ?? and some gif display to tell you what the glyph
should look like

3. apply the patch and rebuild
4. visit that page again and you will see the text appear

Comment 7

17 years ago
* Why do the two new functions reuturn PRBool instead of nsresult? And the
caller ingores the result.
* Please add "::" like ::ATSUSetTextPointerLocation.
* There are some lines with wrong indentation, please fix them.
(Assignee)

Comment 8

17 years ago
*** Bug 135219 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: review
(Assignee)

Comment 9

17 years ago
this patch need to be merged with the mathml landing

Updated

17 years ago
Summary: support surrogate characer rendering under Mac. → support surrogate character rendering under Mac.
(Assignee)

Comment 10

17 years ago
Created attachment 95431 [details] [diff] [review]
patch 1.1

Comment 11

17 years ago
Comment on attachment 95431 [details] [diff] [review]
patch 1.1

r=nhotta
Attachment #95431 - Flags: review+
(Assignee)

Comment 12

17 years ago
sfraser: can you sr= this one ?

Updated

17 years ago
Blocks: 112436

Comment 13

17 years ago
Comment on attachment 95431 [details] [diff] [review]
patch 1.1

sr=sfraser
More comments in the code would be appreciated (maybe explain to those of us
who don't know what the surrogate stuff is all about).
Attachment #95431 - Flags: superreview+
(Assignee)

Comment 14

17 years ago
fixed and land into trunk
add rbs to the bug
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
Verified gb18030 surrogate characters are displayed fine on 08-16 trunk build /
Mac 10.1.5.
Status: RESOLVED → VERIFIED

Comment 16

17 years ago
batch: adding topembed per Gecko2 document
http://rocknroll.mcom.com/users/marek/publish/Gecko/Gecko2Tasks.html
Keywords: topembed

Updated

16 years ago
Blocks: 176349
(Assignee)

Updated

16 years ago
Depends on: 180372
(Assignee)

Updated

16 years ago
No longer blocks: 157673
You need to log in before you can comment on or make changes to this bug.