Closed Bug 1282788 Opened 3 years ago Closed 3 years ago

Intermittent devtools/client/netmonitor/test/browser_net_image-tooltip.js | Test timed out -

Categories

(DevTools :: Netmonitor, defect, P3)

defect

Tracking

(firefox50 unaffected, firefox51 unaffected, firefox52 fixed)

RESOLVED FIXED
Firefox 52
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: arai)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
There was a huge spike in the frequency of these time outs -- https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1282788&endday=2016-11-08&startday=2016-11-06&tree=trunk. Due to the change in bug 1260403?
Flags: needinfo?(arai.unmht)
Thanks.
it looks like I forgot to update the number in waitForNetworkEvents argument.
will fix shortly
Assignee: nobody → arai.unmht
Flags: needinfo?(arai.unmht)
I should've updated this line, since now 8 XHRs:

https://dxr.mozilla.org/mozilla-central/rev/f13e90d496cf1bc6dfc4fd398da33e4afe785bde/devtools/client/netmonitor/test/browser_net_image-tooltip.js#28-29
>  // 7 XHRs as before + 1 extra document reload
>  onEvents = waitForNetworkEvents(monitor, 8);

To avoid this kind of mistake, I added CONTENT_TYPE_WITHOUT_CACHE_REQUESTS constant, and used it everywhere, including the line above.
it's now replaced with `CONTENT_TYPE_WITHOUT_CACHE_REQUESTS + 1`
Attachment #8808800 - Flags: review?(poirot.alex)
Comment on attachment 8808800 [details] [diff] [review]
Add constant for the number of requests in html_content-type-without-cache-test-page.html.

Review of attachment 8808800 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the prompt fix!
Attachment #8808800 - Flags: review?(poirot.alex) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/2290c629fff0b239047e3835313e12db82be4772
Bug 1282788 - Add constant for the number of requests in html_content-type-without-cache-test-page.html. r=ochameau
https://hg.mozilla.org/mozilla-central/rev/2290c629fff0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Doesn't even seem to have slowed down, much less stopped.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
the failure doesn't happen for me locally, even with --run-until-failure, on m-c 336759fad462

anyway, I suspect it's from 1 more request added by bug 1260403, and especially scroll caused by overflow.
I'll add dedicated test file for tooltip, that has only 1 request.
Blocks: 1260403
one more possible issue is that the test doesn't wait for the tooltip to be hidden before starting 2nd test.
in 2nd test, the position of the icon should be changed, because there's first request for HTML file.
so that the tooltip may cover the icon of the 2nd test, depends on the direction of the tooltip opened,

will fix that also.
Added html_image-tooltip-test-page.html that contains only 1 XHR for image.
also, added hideTooltipAndVerify to browser_net_image-tooltip.js that hides the tooltip and waits for it, between 1st and 2nd tests.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c2b48c94840b9bbc13380050aca3e589f909161c
Attachment #8809306 - Flags: review?(poirot.alex)
Comment on attachment 8809306 [details] [diff] [review]
Part 2: Adde dedicated HTML file for browser_net_image-tooltip.js.

Review of attachment 8809306 [details] [diff] [review]:
-----------------------------------------------------------------

Note that is a typo in the commit message: s/Adde/Add/

::: devtools/client/netmonitor/test/browser_net_image-tooltip.js
@@ +101,5 @@
> +    let onHidden = tooltip.once("hidden");
> +    let win = element.ownerDocument.defaultView;
> +    EventUtils.synthesizeMouseAtCenter(element, {type: "mousemove"}, win);
> +    return onHidden;
> +  }

I don't see the value in having two distinct functions here?

::: devtools/client/netmonitor/test/head.js
@@ +22,5 @@
>  const CONTENT_TYPE_WITHOUT_CACHE_URL = EXAMPLE_URL + "html_content-type-without-cache-test-page.html";
>  const HTTPS_CONTENT_TYPE_WITHOUT_CACHE_URL = HTTPS_EXAMPLE_URL + "html_content-type-without-cache-test-page.html";
>  const CONTENT_TYPE_WITHOUT_CACHE_REQUESTS = 8;
> +const IMAGE_TOOLTIP_URL = EXAMPLE_URL + "html_image-tooltip-test-page.html";
> +const IMAGE_TOOLTIP_REQUESTS = 1;

As this is only used in browser_net_image-tooltip.js, we can move these two variable there.
Attachment #8809306 - Flags: review?(poirot.alex) → review+
(In reply to Alexandre Poirot [:ochameau] from comment #14)
> ::: devtools/client/netmonitor/test/browser_net_image-tooltip.js
> @@ +101,5 @@
> > +    let onHidden = tooltip.once("hidden");
> > +    let win = element.ownerDocument.defaultView;
> > +    EventUtils.synthesizeMouseAtCenter(element, {type: "mousemove"}, win);
> > +    return onHidden;
> > +  }
> 
> I don't see the value in having two distinct functions here?

which two functions do you mean?
you mean that we should move the body of hideTooltipOn into hideTooltipAndVerify, or something else?
Flags: needinfo?(poirot.alex)
(In reply to Tooru Fujisawa [:arai] from comment #15)
> (In reply to Alexandre Poirot [:ochameau] from comment #14)
> > ::: devtools/client/netmonitor/test/browser_net_image-tooltip.js
> > @@ +101,5 @@
> > > +    let onHidden = tooltip.once("hidden");
> > > +    let win = element.ownerDocument.defaultView;
> > > +    EventUtils.synthesizeMouseAtCenter(element, {type: "mousemove"}, win);
> > > +    return onHidden;
> > > +  }
> > 
> > I don't see the value in having two distinct functions here?
> 
> which two functions do you mean?
> you mean that we should move the body of hideTooltipOn into
> hideTooltipAndVerify, or something else?

Yes these two.
Flags: needinfo?(poirot.alex)
(In reply to Alexandre Poirot [:ochameau] from comment #16)
> > which two functions do you mean?
> > you mean that we should move the body of hideTooltipOn into
> > hideTooltipAndVerify, or something else?
> 
> Yes these two.

I see, thanks :)
https://hg.mozilla.org/integration/mozilla-inbound/rev/2716f83ffcc0d9adbe37cc7bd4b06a54e4a81abd
Bug 1282788 - Part 2: Add dedicated HTML file for browser_net_image-tooltip.js. r=ochameau
https://hg.mozilla.org/mozilla-central/rev/2716f83ffcc0
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.